Re: VMWare under Knoppix 3.4
[quote="timread"]
Quote:
Originally Posted by scottknl
I think that depends upon the VMWare version. Doing what you suggested I was also able to install the version 4.0.5 but not the newer 4.5.1 which gave me an error:
make: Entering directory `/tmp/vmware-config0/vmnet-only'
bridge.c: In function `VNetBridgeReceiveFromVNet':
bridge.c:346: structure has no member named `sk_wmem_alloc'
make: *** [bridge.o] Error 1
make: Leaving directory `/tmp/vmware-config0/vmnet-only'
Unable to build the vmnet module.
Never mind ... the version 4.0.5 works fine.
I changed "sk_wmem_alloc" to "wmem_alloc" within the vmnet.tar (-> bridge.c) and then it runs fine. (There exist a compability macro to do this automatically but it seems not to work proper)
--
Gerald
KNOPPIX 3.5 LinuxTag 2004 DVD Edition
I can't start a new topic, but anybody knows where I can buy this new DVD version? I think Knoppix.net should sell it right on their site - I want to buy this DVD from the Knoppix team directly to support the development.
security Hole in 2.4.x and 2.6.x Kernel
I think this means another Knoppix 3.4 with kernel 2.6.7 :)
New Linux Security Hole Found
http://story.news.yahoo.com/news?tmp...4&sid=96120751
Mon Jun 14, 1:08 PM ET
Add Technology - Ziff Davis to My Yahoo!
Steven J. Vaughan-Nichols - eWEEK
A Linux (news - web sites) bug was recently uncovered by a young Norwegian programmer that, when exploited by a simple C program, could crash most Linux 2.4 or 2.6 distributions running on an x86 architecture.
Torvalds already has the problem well in hand, he said. "I fixed it in my [source code] tree a few days ago, so it's in the current snapshots, and if I wasn't in the middle of a move [to Portland, Ore.] I'd have released a 2.6.7 already. As it is, I'll hopefully have it done by tomorrow [June 15].
knoppix26 looks for IDE CD when it's a SCSI CD( C't ver too)
As I re-posted in the v3.4 C't Edition thread, there is still a problem with the 2.6 kernel boot process which will look for the Knoppix CD on IDE bus when it's really on the SCSI bus.
Is there anyway to force it to look on hte SCSI bus or do I need to copy the CD to the hard disk and have it look/run from there? TIA.