Error messages when loading persistant image
I created a persistant disk image on the hard disk using the menu "Knoppix->Configure->Create a persistent Knoppix disk image". After I create it, I reboot and when I get the persistent image dialog, I answer yes and the image loads with no errors. The second time I reboot and every time thereafter, I get the list of error messages shown at the end of this post. I have a newer laptop using Knoppix 5.1.1 DVD and its hard drive is a SATA drive and is recognized as sda. I have an older desktop using the Knoppix 5.1.1 CD and its hard drive is recognized as hda. The same thing happens on both computers. I googled this and found a few people that have had this problem in the past but no solutions were given. I have tried formatting the partition holding the persistent image as both ext2 and ext3 and the same thing happens in both cases. Even though I get these error messages, my settings seem to be getting saved from one session to the next. Should I just ignore these messages?
note - I tried an experiment once and modified the exit script to output the error messages when the umount command was given and the message was something like "device busy" or "file system busy" - sorry, I didn't write it down :(
note2 - This sounds very similar to a problem that was just posted today by Alexey931 titled "USB Flash unmounted incorrectly on every boot".
Here are the messages:
************************************************** ******************************
e2fsck 1.40-WIP (14-Nov-2006)
/media/sda6/knoppix.img was not cleanly unmounted, check forced.
....
Deleted inode xx has zero dtime. Fix? yes
.....
Block bitmap differences: ......................
Fix? yes
Free block counts wrong for group #0 .....
Fix? yes
Free block counts wrong .............
Fix? yes
Inode bitmap differences: ..............
Fix? yes
Free inode count wrong for group #0 ..............
Fix? yes
Free inodes count wrong .........................
Fix? yes