Results 1 to 6 of 6

Thread: lilo with two linux versions

Hybrid View

  1. #1
    Junior Member
    Join Date
    May 2004
    Posts
    3

    lilo with two linux versions

    Before installing Knoppix on my HD, I had XP-Home and Mandrake as a dual boot in lilo. My plan was to install Knoppix and have a triple boot - XP, Mandrake, and Knoppix 3.3. However, the Knoppix HD install overwrote the Mandrake, so I used the Mandrake CD to rebuild lilo with XP and Mandrake, and then tried to add the Knoppix entry by hand. My /etc/lilo.conf looks like this:
    boot=/dev/hda
    map=/boot/map
    vga=normal
    default="windows"
    keytable=/boot/us.klt
    prompt
    nowarn
    timeout=100
    message=/boot/message
    menu-scheme=wb:bw:wb:bw
    other=/dev/fd0
    label="floppy"
    unsafe
    image=/boot/vmlinuz
    label="Mandrake"
    root=/dev/hdb5
    initrd=/boot/initrd.img
    append="devfs=mount hdd=ide-scsi acpi=off"
    read-only
    image=/boot/vmlinuz
    label="failsafe"
    root=/dev/hdb5
    initrd=/boot/initrd.img
    append="failsafe devfs=nomount hdd=ide-scsi acpi=off"
    read-only
    other=/dev/hda1
    label="windows"
    table=/dev/hda
    image=/boot/vmlinuz
    label="Knoppix"
    root=/dev/hdb7
    initrd=/boot/initrd.gz
    read-only

    Knoppix boots part way, then hangs. Do I need to change the Knoppix entry somehow? The root directory is good.

    Thanks,
    Mike

  2. #2
    Senior Member registered user
    Join Date
    Mar 2004
    Location
    Berlin
    Posts
    436
    First of all, use indentation in your source, and the 'code' - button, to
    display it more readable, like this:
    Code:
    label="Mandrake"
    	root=/dev/hdb5
    	initrd=/boot/initrd.img
    	image=/boot/vmlinuz
    label="failsafe"
    	root=/dev/hdb5
    	initrd=/boot/initrd.img
    	other=/dev/hda1
    label="windows"
    	table=/dev/hda
    	image=/boot/vmlinuz
    label="Knoppix"
    	root=/dev/hdb7
    	initrd=/boot/initrd.gz
    Second:
    'Mandrake' and ane 'windows' use the same /boot/vmlinuz?
    'Mandrake' and ane 'failsafe' use the same /boot/initrd.img?

    I guess your knoppix-entry needs to be
    initrd=/mnt/hdb7/boot/initrd.gz
    or whereever your hdb7 is mounted to, when running lilo.
    The 'image'-entries should point to the actually mounted device accordingly.

    Therefore your Mandrake:lilo will look different than your knoppix-lilo.
    Note: only the 'root'-entrys are started with '/dev/' - the others shall be in the filesystem-notation.

  3. #3
    Junior Member
    Join Date
    May 2004
    Posts
    3
    Thanks for your reply. Below is a repost of my lilo.conf, hopefully with indentation shown, which makes the logic much clearer. Unfortunately, adding "[b]" to the Knoppix section didn't help. The error that I'm getting says that Knoppix can't start the display manager. Any help will be much appreciated.

    Code:
    other=/dev/fd0
    	label="floppy"
    	unsafe
    image=/boot/vmlinuz
    	label="Mandrake"
    	root=/dev/hdb5
    	initrd=/boot/initrd.img
    	append="devfs=mount hdd=ide-scsi acpi=off"
    	read-only
    image=/boot/vmlinuz
    	label="failsafe"
    	root=/dev/hdb5
    	initrd=/boot/initrd.img
    	append="failsafe devfs=nomount hdd=ide-scsi acpi=off"
    	read-only
    other=/dev/hda1
    	label="windows"
    	table=/dev/hda
    image=/boot/vmlinuz
    	label="Knoppix"
    	root=/dev/hdb7
    	initrd=/boot/initrd.gz[b]
    	read-only

  4. #4
    Senior Member registered user
    Join Date
    Mar 2004
    Location
    Berlin
    Posts
    436
    Much better overview - isn't it?

    Well - bold inside code doesn't work.

    How is the display-manager question related to lilo? not at all - I guess.

    But again my question:
    Your /boot - directory is the same for Mandrake, failsafe and knoppix?
    Assuming this is the knoppix-lilo.conf file.
    I assume your Mandrake-boot-dir is on hdb5, which is maybe mounted to /mnt/hdb5 and then
    initrd=/mnt/hdb5/boot/initrd.img would be the right entry for Mandrake and failsafe.

    For the display-manager question start a new Thread, with appropriate title.

  5. #5
    Junior Member
    Join Date
    May 2004
    Posts
    3
    This is the Mandrake lilo-conf file. It was created automatically by the Mandrake install CD.

    I then used the Mandrake Control Center to add the Knoppix entry, but had to hand-edit it so that root pointed to the correct partition (hdb7). I basically copied the format that Mandrake automatically generated for failsafe and Mandrake since those work fine.

    It seems like Knoppix boots, but something is wrong with the display-manager. As suggested, I'll start a new thread, with appropriate title and exact error messages.

    I can boot into Knoppix fine using the boot floppy that I created on install. The CD also works fine, of course.

    Again, thanks for your help.
    Mike

  6. #6
    Senior Member registered user
    Join Date
    Mar 2004
    Location
    Berlin
    Posts
    436
    If everything (from lilo) works - fine, but if this is the Mandrake-lilo.conf,
    I would still prove the entries 'image' and 'initrd'
    Code:
    image=/mnt/hdb7/boot/vmlinuz
       label="Knoppix"
       root=/dev/hdb7
       initrd=/mnt/hdb7/boot/initrd.gz[b]
       read-only
    They are really located on /dev/hdb5 (which is your Mandrake root-dir)?

Similar Threads

  1. Reinstall lilo to hda, using hda lilo.conf and knoppix live
    By tomjermy in forum Hardware & Booting
    Replies: 1
    Last Post: 03-17-2005, 01:07 AM
  2. how to hd install 4 versions of linux
    By ramaswamyps in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 03-05-2005, 01:42 AM
  3. Old versions of Knoppix?
    By hrymur in forum General Support
    Replies: 1
    Last Post: 06-12-2004, 05:02 AM
  4. versions
    By pistatio56 in forum General Support
    Replies: 1
    Last Post: 03-01-2004, 09:56 AM
  5. versions, 3.2 3.3 3.4
    By waynejkruse10 in forum The Lounge
    Replies: 0
    Last Post: 11-15-2003, 11:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p picture

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p

$499.88



Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram  2x 550W PSU No HDD picture

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD

$275.00



Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb picture

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb

$374.99



Dell Poweredge C4130 2x LGA2011-3 1U 4x GPU Rackmount Server CTO (NO CPU/NO RAM) picture

Dell Poweredge C4130 2x LGA2011-3 1U 4x GPU Rackmount Server CTO (NO CPU/NO RAM)

$299.95



Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD picture

Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD

$378.93



Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W

$409.99



Dell Poweredge R810 4x Xeon X7560 2.26ghz 32-Cores | 256GB | 3x Trays | H700 picture

Dell Poweredge R810 4x Xeon X7560 2.26ghz 32-Cores | 256GB | 3x Trays | H700

$289.99



Dell Poweredge R730xd 12LFF + 2SFF  2x10/1Gbe H730 Mini 2x 750W  Server picture

Dell Poweredge R730xd 12LFF + 2SFF 2x10/1Gbe H730 Mini 2x 750W Server

$348.00



Dell Poweredge R620 10x 2.5

Dell Poweredge R620 10x 2.5" bay with 256GB (16x16gb) DDR3, 2x E5-2690v2, H710

$349.99



Dell PowerEdge R740 E38S001 Server E38S picture

Dell PowerEdge R740 E38S001 Server E38S

$660.00