Results 1 to 10 of 10

Thread: Kernel Panic - After successful install

  1. #1
    Junior Member
    Join Date
    Aug 2004
    Posts
    5

    Kernel Panic - After successful install

    Okay, here's the deal. I'm trying to install linux on my oldest comp. It's not pretty.

    It's a p1, 133 mhz processor with only 64 megs of ram. It has two hard disks, the master being 5.5 gb and the slave being 1.6 gb. I have no intentions of using kde on this thing. All I need is to install it to the hard drive, and have it able to boot up into the bash shell. I have had so many problems with this, it's not even funny.

    My first problem came up when I was trying to partiton the drives. I've come to the conclusion it's not possible to do in the bash shell. Originally, I ran "knoppix-installer" and just tried to partition from that. Unfortanately, it wouldn't let me open either of my two drives to partition. I believe the error message was something along the lines of "could not write to disk - drive opened read only." Okay, so I figured this was no big deal. I mounted both of the disks as read-write and tried again, same error. I did all sorts of variations of mounting and unmounting, and eventually I stopped running the installer at all and just going straight to "cfdisk." Never worked. In the end, I booted up into kde. About an half an hour later, I was at the desktop. I ran the installer from there, and for some reason, it let me partition the drives (in kde, knoppix-installer uses qtparted not "cfdisk", which probably has something to do with it right there...) Anyway, I finally got my drives partitioned.

    hda1 ext2 5 gigs
    hda2 swap .5 gigs

    hdb wasn't partitioned because qtparted was being real tempermental and wouldn't let me do anything, but I doubt I'll be needing that much hard drive space anyway, since I'm running this text only. Also, I made the swap file only 500 mb because I figured, there is NO way I would ever need a full gig of memory running in just text.

    7 hours later, the installation was completed. LILO was installed to the mbr and it CLAIMED that it was installed succesfully. I made a boot disk as well. I restarted and was happy to see LILO smiling back at me with the three kernel options (knoppix, 2.4, or 2.6). However, no matter which one I choose, Knoppix will not boot. It appears to load everything right, and is going through the normal boot messages, when suddenly, it says:

    Kernel Panic: Attempted to kill init

    And that's where it hangs. Ctrl+C does nothing, I can't switch to other shells using alt+f#, and it just isn't good in general. Now if I could at least get into a bash shell to fix this, I wouldn't be quite so frustrated, but the problem is, I can't even make it to a shell. And if I boot up to a cd, I can't change settings on the hd because everything runs from the cd. That probably made no sense at all. For instance, if I change lilo.conf on the hd, I have to run lilo. Problem is, LILO realizes that knoppix is the current root partition, and instead of trying to recognize lilo.conf on my hard disk, it goes and looks at the knoppix one instead. I'm really out of ideas here, so anything you can suggest would be appreciated. Thanks.

    P.S. I'm installing Knoppix 3.4

  2. #2
    Senior Member
    Join Date
    Nov 2003
    Posts
    1,323
    You can boot the cd and change root into the hd install with:
    su
    mount /dev/hda1 /mnt/hda1
    chroot /mnt/hda1

    Then you can run lilo or if you just want to run lilo:
    chroot /mnt/hda1 lilo -v
    Exit from chroot with ctrl-d

    BTW: You can get a lighter gui with the cd using the cheatcode desktop=icewm

  3. #3
    Junior Member
    Join Date
    Aug 2004
    Posts
    5
    Thanks for the advice, I'll give it a try and let you know how it works out.

  4. #4
    Junior Member
    Join Date
    Aug 2004
    Posts
    5
    Okay, so I have some more light to shed on the problem.
    First of all, thank you markus for your advice. I don't think the probelem lies in LILO however. After looking over the LILO file thoroughly, it appears that it's already been configured properly.

    Here is the last output before the computer hangs during startup.
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~

    umount: devfs: not mounted
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    mount: fs type devfs not supported by kernel
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    end_request: I/O error, dev 2:00 (floppy), sector 0
    umount: devfs: not mounted
    /sbin/init: 423: cannot open dev/console: No such file
    Kernel Panic: Attempted to kill init!

    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    I don't know how I managed to miss it before, but the lack of dev/console seems to be a glaring problem...Unfortunately, I have no idea how to fix it. After looking through the knoppix cd, I couldn't even find a file called "console".

    Any ideas would be welcomed. And by the way, this is the third time I've installed and had this problem, so I don't believe a reinstall will help, and in additon, I've already had a successful install with this cd on another computer that's working fine. Of course, the other computer it was installed to was about 3 years newer.....

  5. #5
    Senior Member registered user
    Join Date
    Mar 2004
    Location
    Berlin
    Posts
    436
    Perhaps something with your inittab.

    Review /etc/inittab and man init

    Yes - a very vague hint...
    my /dev/console is

    crw------- 1 root tty 5, 1 2004-01-22 22:16 /dev/console

    is your system a 2.6 kernel?
    Do you have a devfs - entry in /etc/fstab?

  6. #6
    Senior Member registered user
    Join Date
    Jun 2004
    Posts
    788
    Could it be you have a bad hard disk (bad block)?

  7. #7
    Senior Member
    Join Date
    Nov 2003
    Posts
    1,323
    First check the cd with the testcd cheatcode, although it seems to have worked on your other computer.
    How about trying with the nodma bootoption. Perhaps the bios on your older box doesn't support dma?

  8. #8
    Senior Member registered user
    Join Date
    Mar 2004
    Location
    Berlin
    Posts
    436
    I don't understand what indicates a broken harddisk or cd - ...

    Code:
    man makedev
    could help to generate /dev/console

  9. #9
    Junior Member
    Join Date
    Aug 2004
    Posts
    5
    Ok, so, it's not fixed, but I'm able to live with my current setup. Making my /dev/console the same as unknowns didn't work. Also, my inittab seemed to be configured right as well. A bad block on the hard disk is possible, though I find it unlikely. Also, nodma makes no difference, and the cd is working properly as well. I was able to run "./MAKEDEV console", from the /dev directory. At this point, I'm unable to check and see if this has worked, since I've left for vacation. However I have made do with what I have.

    I booted up with the box with the knoppix cd, and mounted the hard drive knoppix was installed to. using "chroot" I switched the root directory to the hard drive install. I set everything up there, so I'm not able to ssh into my box from anywhere. I'm still gonna try and get it to work fully without the cd when I get back. Thanks for all the help!

  10. #10
    Junior Member
    Join Date
    Jul 2004
    Posts
    4
    Hi,

    I got same problem not yet solved

    After a succefully installation I got kernel panic after LILO selection (it is the same with knoppix, debian or beginner install metod):

    with linux
    mount: fs type devfs not supported by kernel
    pivot_root: no such file or dir
    /sbin/init:423 : cannto open dev/console


    with 2.4 kernel
    kernel panic: vfs: unable to mount root fs on 03:05


    with kernel 2.6
    kernel panic: vfs: unable to mount root fs on hda5

    Your kernel panic contains the same arguments?

Similar Threads

  1. Boot error and kernel panic after 3.4 install
    By dinacre in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 07-13-2004, 11:15 PM
  2. Errors and kernel panic during boot (2.6 Kernel)
    By gitarzysta in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-03-2004, 08:36 PM
  3. Successful install
    By HaroldK in forum Hdd Install / Debian / Apt
    Replies: 20
    Last Post: 11-08-2003, 09:17 PM
  4. Successful install
    By ndrake in forum Hardware & Booting
    Replies: 0
    Last Post: 09-28-2003, 08:56 PM
  5. Modified kernel results in Kernel Panic - No init found.
    By tji in forum Customising & Remastering
    Replies: 4
    Last Post: 06-12-2003, 06:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray picture

Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray

$39.99



Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A

$64.00



Seagate ST12000NM0127 12TB 256MB 7200RPM 3.5

Seagate ST12000NM0127 12TB 256MB 7200RPM 3.5" SATA 6.0Gb/s Enterprise Hard Drive

$318.99



DELL 2TB Enterprise HDD (7200RPM, 3.5

DELL 2TB Enterprise HDD (7200RPM, 3.5", SATA III, 128MB Cache) HUS722T2TALA600

$49.95



Seagate ST500DM009 BarraCuda 500 GB 3.5

Seagate ST500DM009 BarraCuda 500 GB 3.5" SATA III Desktop Hard Drive

$14.99



Seagate ST4000NM0034 Enterprise 4TB 7200RPM SAS 12Gb/s HDD v4 picture

Seagate ST4000NM0034 Enterprise 4TB 7200RPM SAS 12Gb/s HDD v4

$39.00



Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE picture

Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE

$68.99



HGST HUS724040ALA640 HDD 4TB SATA 6Gb/s 7.5K 3.5

HGST HUS724040ALA640 HDD 4TB SATA 6Gb/s 7.5K 3.5" 0F19459 512 b/s

$78.00



(ST8000NM0045) SEAGATE ENTERPRISE 8TB 7200RPM 4Kn SATA 6Gb/s 3.5

(ST8000NM0045) SEAGATE ENTERPRISE 8TB 7200RPM 4Kn SATA 6Gb/s 3.5" HARD DRIVE

$199.99



Seagate ST8000NM0075 Enterprise Capacity 3.5 HDD 8TB SAS Hard Drive 8TB EXOS picture

Seagate ST8000NM0075 Enterprise Capacity 3.5 HDD 8TB SAS Hard Drive 8TB EXOS

$184.99