Results 1 to 5 of 5

Thread: Captive-NTFS just disappears when I try to use it.

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jul 2004
    Posts
    2

    Captive-NTFS just disappears when I try to use it.

    It starts scanning and next thing I know its gone. Running it again looks like its just starting over from scratch. I'm trying to get my NTFS safely writeable. I'm also a knoppix-noo,b so go easy on me.

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Cleveland, OH
    Posts
    228
    Same issue for me...

    My details are that I am running Knoppix 3.4_05.17.04

    Actually, I have never been able to get this working on my Windows 2000 pc. It never finds the files on my NTFS partition, or in a directory on an ext2 partion, or even if I copy them into /var/lib/captive as suggested.

    Does anyone have this running or have some pointers?

    ~pau1

  3. #3
    Junior Member
    Join Date
    Jul 2004
    Posts
    2
    My brother has the same issue. Here's what I ended up doing. Copied them to a flash drive from my other computer and then dropped them on the desktop on my laptop. I then skipped the search and did the second browse option. It found them and appeared to have accepted and loaded them. I then used the console commands to mount the drive that I found elsewhere in this forum (mount -t captive-ntfs /dev/hdX /mnt/hdX) and it appeared to have mounted the drive with the captive-ntfs driver. My problem now is though is I get access denied errors and I'm not sure if its because it still isn't loaded right or if its an NTFS permissions error. This laptop is a work laptop and though I am a local administrator on it, we have the file system locked down so that the only place our users can save is the server folder. Does the captive-ntfs driver respect NTFS permissions?

  4. #4
    Junior Member
    Join Date
    Aug 2004
    Location
    Innsbruck Austria
    Posts
    1
    Try to copy ntfs.sys and ntoskrnl.exe from Windows XP into /var/lib/captive.
    The drivers from Windows 2000 cause problems, see

    http://www.jankratochvil.net/piperma...il/000341.html

    When I was trying to mount NTFS with the drivers from Windows 2000 (Knoppix 3.4 c't Edition), I got the following message.

    Captive[1942]: sandbox: FATAL: file signal.c: line 203 (sigaction_SIGSEGV): assertion failed: (reg_eip_aligned!=NULL)

    After copying ntfs.sys and ntoskrnl.exe from a Windows XP installation, the message was gone.

  5. #5
    Junior Member registered user
    Join Date
    Oct 2004
    Posts
    12
    Quote Originally Posted by joehtg
    Try to copy ntfs.sys and ntoskrnl.exe from Windows XP into /var/lib/captive.
    The drivers from Windows 2000 cause problems, see

    http://www.jankratochvil.net/piperma...il/000341.html

    When I was trying to mount NTFS with the drivers from Windows 2000 (Knoppix 3.4 c't Edition), I got the following message.

    Captive[1942]: sandbox: FATAL: file signal.c: line 203 (sigaction_SIGSEGV): assertion failed: (reg_eip_aligned!=NULL)

    After copying ntfs.sys and ntoskrnl.exe from a Windows XP installation, the message was gone.
    I had troubles mounting NTFS-captive as well. I copied the essential drivers myself, but still I got some error message "disc is dirty etc. etc."

Similar Threads

  1. unable to write to NTFS with captive-ntfs
    By harry66 in forum General Support
    Replies: 1
    Last Post: 03-30-2005, 05:03 PM
  2. Captive NTFS on Knoppix 3.6 and WInXP / NTFS hard drive
    By itaydagani in forum MS Windows & New to Linux
    Replies: 3
    Last Post: 02-02-2005, 12:53 AM
  3. Captive NTFS
    By r204d in forum General Support
    Replies: 1
    Last Post: 01-14-2005, 02:22 AM
  4. captive ntfs - mount ntfs (reade/write) through icon
    By terminator in forum General Support
    Replies: 0
    Last Post: 05-12-2004, 10:52 PM
  5. captive ntfs
    By guillaumecote in forum Ideas
    Replies: 15
    Last Post: 04-21-2004, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


IBM System X3850-X5 Server w/4x Intel  Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD picture

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD

$1599.99



IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU picture

IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU

$225.00



Unused IBM 09P0037 MAINBOARD For  RS/6000 7044-170 P-Series picture

Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series

$375.00



IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM

$179.99



IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU picture

IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU

$999.99



IBM System x3550 M3 1U Server 2x Xeon E5645, 192GB RAM, 2x 300GB HDD (7944-AC1) picture

IBM System x3550 M3 1U Server 2x Xeon E5645, 192GB RAM, 2x 300GB HDD (7944-AC1)

$150.00



IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES picture

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES

$110.30



IBM 02CL197 FLASH SYSTEM 840-900 LITHIUM ION SERVER BATTERY MODULE 990854 picture

IBM 02CL197 FLASH SYSTEM 840-900 LITHIUM ION SERVER BATTERY MODULE 990854

$225.00



Lot of 4 IBM 52Y4089 POWER7 CPU Processor Modules Server CPUs picture

Lot of 4 IBM 52Y4089 POWER7 CPU Processor Modules Server CPUs

$49.99



Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs picture

Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs

$54.99