Results 1 to 6 of 6

Thread: Konqeror and SMB

  1. #1

    Konqeror and SMB

    I'm having dificulty as of the 03/23/2003 release with using the smb prefix in konqeror. I can mount network shares fine using the comand line, so samba apears to be working. But I can no longer browse or connect to shares using Konqeror. I recieve an error to the effect of : Error loading kio_smb.
    I could and still can browse if I use the 03/21/2003 release. Is anyone else having this problem or is it just me?

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041

    Re: Konqeror and SMB

    Since Knoppix touches the "unstable" parts of the Debian archives, something probably broke.

    My advice is to keep at least 1 old .iso rev around for just these types of contingencies. Then you download the latest rev when it comes out, and see if the problem was fixed.

    Alternatively, install to HD - and use apt-get update, apt-get upgrade to get the latest stuff without having to wait.

    Knoppix is an interesting mix, BTW. I have to use ' apt-get install gaim/unstable ' for IM to work, and ' apt-get install ntop/stable ' for network monitoring to work. (shrug) Knoppix is still the coolest thing I've ever seen.

    Quote Originally Posted by Gene Simmons
    I'm having dificulty as of the 03/23/2003 release with using the smb prefix in konqeror. I can mount network shares fine using the comand line, so samba apears to be working. But I can no longer browse or connect to shares using Konqeror. I recieve an error to the effect of : Error loading kio_smb.
    I could and still can browse if I use the 03/21/2003 release. Is anyone else having this problem or is it just me?

  3. #3
    Junior Member
    Join Date
    May 2003
    Posts
    2

    Re: Konqeror and SMB

    I have the same problem (the same error) with 04/18/2003 release
    and can't find answer yet.

  4. #4

    Re: Konqeror and SMB

    Quote Originally Posted by Gene Simmons
    I'm having dificulty as of the 03/23/2003 release with using the smb prefix in konqeror. I can mount network shares fine using the comand line, so samba apears to be working. But I can no longer browse or connect to shares using Konqeror. I recieve an error to the effect of : Error loading kio_smb.
    I could and still can browse if I use the 03/21/2003 release. Is anyone else having this problem or is it just me?
    Same error here too. I found a workaround though.

    At a root shell prompt, mount the remote Windows share (or samba share) using mount -t smbfs -0 {relevant samba mount options here)}//server/share /mnt/{mount point here... I use test}.

    Now use Konqueror and browse to /mnt/mountpoint. You should be able to interact with the system as normal... and the bonus is that you can write (if the gid and uid was set to knoppix and the share was mounted read and write) to the system as well (overcoming Konqueror's smb plugin inability to write to samba shares).

    Try it...

    It works.

  5. #5
    Junior Member
    Join Date
    May 2003
    Posts
    2
    It is not very convenient to mount share each time. Especially if your network more than 200 computers and you want simply to browse contents of the share. Prefix smb: is better and it is a pity that it does not work.

  6. #6
    Member registered user
    Join Date
    May 2003
    Location
    Los Angeles, California, USA
    Posts
    40
    If you want to mount multiple shares easily goto LinNeighborhood then click on "Options | Browse Entire Network" select "Browse as User" and input your credentials; click OK. Once this is done you may have to rescan the network but once you do all of the computer's network shares are visible. Then you can right click a share and mount it and, provided you have configured the "Run File Manager after Mounting" option in "Prefs | Post Mount", even open Konquerer right from there. At the very leat you have easily mounted a share.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Seagate Exos 7E8 4TB 3.5

Seagate Exos 7E8 4TB 3.5" SAS ST4000NM0025

$22.00



Hitachi  / HGST Travelstar HTS541010B7E610 1TB 2.5

Hitachi / HGST Travelstar HTS541010B7E610 1TB 2.5" SATA III HDD

$29.99



New Western Digital WD40EFPX 68C6CN0 4TB 3.5

New Western Digital WD40EFPX 68C6CN0 4TB 3.5" SATA III Internal NAS Red Plus HDD

$137.59



Seagate 14TB Exos X14 7200RPM SATA 6Gb/s 256MB 3.5

Seagate 14TB Exos X14 7200RPM SATA 6Gb/s 256MB 3.5" Enterprise HDD ST14000NM0408

$354.99



Seagate ST6000NM0115 6TB 256MB 7200RPM 3.5

Seagate ST6000NM0115 6TB 256MB 7200RPM 3.5" SATA 6.0Gb/s Enterprise Hard Drive

$159.99



HGST HUS724040ALA640 4TB 7200 RPM SATA 3.5

HGST HUS724040ALA640 4TB 7200 RPM SATA 3.5" Internal Desktop Drive 100% Health

$78.00



Seagate Exos X16 16TB ST16000NM001G 7200RPM Enterprise HDD*USED GREAT CONDITION* picture

Seagate Exos X16 16TB ST16000NM001G 7200RPM Enterprise HDD*USED GREAT CONDITION*

$319.79



Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A

$69.00



Seagate Exos X16 ST10000NM010G 10TB 7200RPM SAS 12Gb/s 3.5

Seagate Exos X16 ST10000NM010G 10TB 7200RPM SAS 12Gb/s 3.5" 512e/4Kn HDD

$199.00



HUS726060ALA640 HGST Ultrastar  6TB SATA 6Gbps 7.2K 3.5

HUS726060ALA640 HGST Ultrastar 6TB SATA 6Gbps 7.2K 3.5" Hard Drive OF21860

$129.99