I am trying to run two commands at startup on my remastered CD. I created a script in /etc/init.d named ARIstartup:
Code:
sudo mount /mnt/hda1
sudo cupsd
I then created a link to this called /etc/rc5.d/S99ARIstartup.

When I boot the system it starts Runlevel: 5 and gets to Starting X11.....
then displays the following messages:

Retrying with Server XFree86(vesa) .
Retrying with Server XFree86(fbdev) .
Error: No suitable X-Server found for your card.

The system has run fine before this script was executed. In fact all I did was change the permissions so the script could run, because it was skipping the script without execute permissions.

I am running this script because I need the hda1 to be mounted with rw permissions and I need print services.

Any help either working around this script or fixing it wouold be greatly appreciated.

Update:

This was not caused by the rc5.d script. The script works fine. There was a problem building the isofs. Problem solved.