-
Senior Member
registered user
Network works...then it doesn't
Weird problem just started with my Toshiba laptop/Netgear pcmcia ethernet card.
It sets up properly & broadcasts for DHCP as part of knoppix-autoconfig script. Then it trashes the pcmcia connection.
Startup messages look some thing like this:
modprobe 8390
modprobe pcnet_cs
./network start eth0
/sbin/ifconfig eth0 up
/sbin/pump -i eth0 > dev/null
All this is as part of knoppix-autoconfig script; I have inserted an 'end of autoconfig script' echo command to aid troubleshooting so I can tell when it exits.
Then, immediately following the autoconfig script, it does the following:
[re]starting pcmcia services (in green)
cardmgr [109] ./network check eth0
cardmgr [109] ./network stop eth0
cardmgr [109] /sbin/pump -r -i eth0
cardmgr [109] modprobe -r pcnet_cs
cardmgr [109] modprobe -r 8390
cardmgr [109] exiting
cardmgr [505] error in file 'config line 2288 unknown device prism_cs
cardmgr [505] open_sock (socket 0) failed device or resource busy
Then it goes on to start cups & samba & startx. At this point I have no net connection. I have checked this by inserting a 'ping' test command at the end of knoppix-autoconfig & again at the start of /etc/init.d/xsession. First ping is OK, second fails.
I doubt if anybody else has actually had this problem, I always seem to get the weird ones, but can anybody help?
Why would this suddenly start doing this? Why/what script is attempting to [re]start pcmcia services & screwing it up. (Note: running from CD it appears not to do this) What controls the startup procedure...what calls knoppix-autoconfig & what is supposed to happen next?
-
Senior Member
registered user
I have partially solved this but still have questions.
Tracking through the startup procedure, knoppix-autoconfig runs first. It correctly identifies & sets up the PCMCIA ethernet card on socket 1. Then knoppix-hd-config runs. It attempts to restart the ethernet card (why??). It succeeds in shutting down the card, removing modules (modprobe -r) pcnet_cs & 8390 but then fails attempting to restart because it finds an open socket (socket 0) which it is unable to close.
I have done a 'workaround' disabling the shutdown part of the process, network now stays up but can somebody explain why knoppix-hd-config wants to do the shutdown/restart in the first place & how do I figure out what socket 0 is doing.
Similar Threads
-
By Silvix in forum Networking
Replies: 0
Last Post: 06-02-2005, 04:02 AM
-
By kpf8655 in forum Hdd Install / Debian / Apt
Replies: 7
Last Post: 07-02-2004, 01:13 PM
-
By Corwin in forum Hdd Install / Debian / Apt
Replies: 2
Last Post: 04-04-2004, 03:29 AM
-
By BluntMan in forum Networking
Replies: 0
Last Post: 11-17-2003, 01:28 AM
-
By Mokoshi in forum Networking
Replies: 1
Last Post: 10-07-2003, 03:04 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS
$199.00

Supermicro 505-2 Server
$280.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99

Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On
$450.00

HP PROLIANT TPS-W003 MICRO- SERVER TOWER Gen 8, 16G RAM
$195.00

Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99

SUPERMICRO CSE-836 XEON E5-1620 v3 @ 3.50GHz, 32GB RAM, NO HDD/OS
$299.99

Supermicro 1027GR-TSF 1U Rackmount Server 2x Xeon 2.3GHz 128GB DDR3
$219.99

Supermicro CSE-216 No CPU No Ram No HDD Tested & Reset
$149.99

Supermicro CSE-216 No CPU No Ram No HDD Tested & Reset
$149.99