Since I've seen many posts across the forums complaining about Knoppix failing to boot from CD where the answer has been to append "nodma" to the boot command line, please alter miniroot to rollover to nodma behavior (at least for the CD drive) if mounting the cd image via DMA fails. Obviously the CD drive works... the syslinux boot prompt loaded and Knoppix began loading.

BTW, I'm also experiencing the nodma issue. Our old computers, Gateway 2000 Pentium 166 and IBM 300GL, work just fine with DMA enabled, but our new computers, IBM NetVista A60, do not work with DMA enabled.

We're trying to make a one-size-fits-all NX-Kiosk CD so our end users can just stick it in and go. As is, we'll have to have 2 versions, one with DMA for the older slower computers and one without DMA for the new computers. We're probably not going to do it because it'll be too confusing for our computer unsavvy users.

Please get the DMA to rollover when it fails to load the CD image.

Thank you.