booting with "knoppix 2" will boot to a comand line... and when x shutsdown it will not reboot.... allowing you to read the x startup and find any errors....
After knoppix boots it detects hardware it says something like x will start one time to configure video for knoppix ...
Then the knoppix screen appears and the speakers say "initiating.." and then, it says "initiating shutdown..." and then x exits without errors and the shutdown the computer.
I've tried on 2 different machines:
* Athlon Xp 1800 with 512 mb DDR PC2700, asus a7v266e nvidia g-force 2 gts 64 mb ram, on viewsonic e773, 2 30gb hard disks on raid 0, sblive mp3, and, of course, mouse and keyboard
* Pentium II 400 on soyo 6be with 384 mb, matrox mga400 32mb on viewsonic e655, 15gb hd, sb16 vibra and, of course, another keyboard and mouse.
I've tried with the vesa option, with different resolutions and the only time it works was when i chose other window manager... i don't remember which but it was ugly (it was not g-nome nor kde).
Anyone know what can i do??
booting with "knoppix 2" will boot to a comand line... and when x shutsdown it will not reboot.... allowing you to read the x startup and find any errors....
Two machines with the same error lead me to suspect the CD itself. Use the MD5 checksum program to ensure that you have a good ISO image. Alternately, you can try re-burning the CD and see if the second copy works better.Originally Posted by _CaLeB_
Thanks for the speed in response.
I've done that and i found 2 errors with the (EE) symbol in front
they say:
MGA failed to load module "MGA.hal" (module does not exist,0)
MGA(0) no V_BIOS found
That's all....
I wonder if it kde or gnome or what ???
i tried startx but i don't know how to choose start kde or gnome or others
T.I.A.
boot up with knoppix 2, and then su to the knoppix user, like this:
su knoppix
your prompt should now be a $ instead of a #
then use an editor to make your .xinitrc file like this:
jpico .xinitrc
which will start jpico a fairly easy to use editor, use vi or ?? if you are familiar with something else then put this line in the file:
startkde
then save the file and use startx.
rock
I've tried to edit the file but when i want to save i get the "I cant read file" or something...
i dunno if it is for the read-olny mounted linux (i think i've readed that on a faq) or that i'm not in the right directory to put it.
Sorry but i am kinda newbie in linux scheme and i don't know where to run...
Thanks

Dell PowerEdge M630 Blade Server 2x Xeon E5-2680 v4, 2F3MP , 4GDP5 ,R10KJ ,JVFVR
$95.20
Dell PowerEdge M640 Blade Barebone Server Dell P/N: HHB006 Tested Working
$149.99
Cisco UCS 5108 Blade Server Chassis Enclosure N20-C6508 4x PSU 8x Fans 2x Fabric
$174.99
AS IS READ DESCRIP. Supermicro SuperServer 6026TT-HIBQRF 12-Bay 4x X8DTT-HIBQF
$215.00
Datto S4P10 1U Blade Rack Server Intel Xeon D-2143IT 2.20GHz 48GB DDR4 4-Bay PSU
$197.76
Dell PowerEdge M620 Blade Server 2x Xeon E5-2680v2 2.8ghz 20-Cores | 128GB
$149.99
Dell PowerEdge VRTX 2.5"x25 Bay Blade Enclosure 4x1600W + 4X M640 (4X Blades)
$1599.99
Dell Poweredge C6400 24x 2.5’’ 2x 2400W 4x C6420 Nodes H330 | 2x SFP | 8x Trays
$799.99
Dell Poweredge VRTX 25Bay 2.5" 2x PERC 8, 2xCMC, I/O 1GB Pass Through, 4x PS
$578.08
AS IS Supermicro SuperServer 6026TT-HIBQRF 12-Bay 4x X8DTT-HIBQF
$410.00