You cant install it on an NTFS partition, create a new one with QParted and make it either ext2 or ext3, then follow the install guides provided on this site.
Hello,
I am considering installing Knoppix(2.6 Kernel)on my ancient Compaq Presario laptop (160 MB RAM, 400 MHz) and setting it up as a dual boot along with Win XP Pro. I have a 20 gig hard disk (no partitions) and it has around 9.5 gigs free on it. The HD uses the NTFS system. I was wondering if anyone could provide a step by step as to how to install Knoppix to a NTFS drive without data loss, how to partition and finally how to set it up so that there is a dual boot option at startup. I am pretty new to all this, any help would be greatly appreciated.
Thanks!
You cant install it on an NTFS partition, create a new one with QParted and make it either ext2 or ext3, then follow the install guides provided on this site.
I think his question was, "can I resize NTFS partitions with QParted without losing data?" AFAIK, the answer is no -- Parted doesn't support NTFS resizing. I know a product called PartitionMagic can, but it is payware.
ntfs resize is incorporated into qtparted as far as i know. it can move the end of a partition only (atleast larst i heard) but...
and best to defrag tha partition a few times just to be sure.
Ok, I'm getting conflicting responses here. Is it safe to use QParted with a 20 GB NTFS HD with the current version of Knoppix to create the the 2 partitions needed (Knoppix+Swap) for a full HD install?
That aside, the dual boot, will I be prompted to set that up within the Knoppix installer, if not, how do i go about accessing it?
A
The drive isnt NTFS, one of your partitions is. If you have enough room you can create more than one partition, but you might need to resize the NTFS one like the other people said. If you have more than 384mb of ram, I would say that it is possible to do without the swap partition.
I just went ahead and ran the install program, everything went well, partitioned, Lilo worked and everthing.
Then when I try and boot into Kernel 2.6, I get the following error
"Process 'update' used obselete bd flush system call" Fix your intscript?
I say yes and the OS continues with its routine, autodetecting devices and such
Then when KDE starts to load I get the following error message
"Writing to the temp directory (/tmp) failed with the error "Permission denied"
"KDE unable to start."
Then this error
"Couldn't stat ksmserver"
And then finally it says I do not have enough memory to start KDE, 82 required and gives me a shell window.
I have 156 MB Ram, how is this possible? Any thoughts would be appreciated...
EDIT: Also have a 350MB Swap Partition
Thanks,
A
seems like a fixable problem? anyone have a solution or heard of something similar?
If not, would a reinstall work perhaps? And if so, do I need to uninstall first or can I just install over the original install?
A

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD
$1599.99
Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series
$375.00
IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU
$225.00
IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM
$179.99
IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU
$999.99
IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES
$110.30
IBM System x3550 M3 1U Server 2x Xeon E5645, 192GB RAM, 2x 300GB HDD (7944-AC1)
$150.00
IBM 02CL197 FLASH SYSTEM 840-900 LITHIUM ION SERVER BATTERY MODULE 990854
$225.00
IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620
$199.99
Lot of 4 IBM 52Y4089 POWER7 CPU Processor Modules Server CPUs
$49.99