the partimage website said there would be an eror is the hardrive was not defraged, but you don't seem to get one.
I am using Knoppix 3.4 to save and restore my Windows XP partition (NTFS) with partimage. After doing this several times without any problems, there is suddenly the problem that after entering all parameters and starting, partimage does not start saving the partition, but displays "0%" for minutes. What can be the reason? "cat /proc/partitions" displays all partitions correctly. I also can save a VFAT partition without problems. I think that too much file fragmentation can not be the problem, because according to the partimage homepage, in this case an error message should occur. The partition to save is 15GB NTFS with about 5GB data and the image should be saved to a large VFAT partition on the same 160GB drive. I chose splitting of image to files of the size 2GB and last time I created this way successfully an image consisting of 2 files smaller than this limit. Unfortunately I don’t know much about Linux.
The only thing that has changed after the last successful image creation is an update of the following 2 BIOS components:
ASUS A7V600 ACPI 1006 - to version 1008
Serial ATA RAID BIOS Setting Utility 2.01 - to version 2.31
Can this be a problem for Knoppix 3.4 or partimage? Is it a good idea to try a newer Knoppix version? After rebooting Windows XP I see a file created by partimage at the correct path but with size zero.
the partimage website said there would be an eror is the hardrive was not defraged, but you don't seem to get one.
That's true. I dont see a corresponding message.
In the meantime I tried a freshly downloaded Knoppix 3.7 with partimage 0.6.4 (instead of 0.6.2 as before): Now partimage exits to the bash prompt and I see an error message saying memory access error (the original german message is "Speicherzugriffsfehler"). So far I remember, partimage diplays usually a window with the main properties of the partition to be save before starting action. But obviously the error occurs before this window is displayed. What can I do?
Thanx for any hint!
--
Wolfgang Beyer
www.wolfgangbeyer.de
You may want to try, nodma as a cheatcode.
It will be very slow but might work.

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD
$1299.99
IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM
$179.99
Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series
$375.00
IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620
$199.99
IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES
$110.30
IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A
$1731.00
IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU
$999.99
Compaq ProLiant 1500R 5/100 rack server, Series 3155, with IBM 2.1GB HD, VINTAGE
$295.00
Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs
$49.99
IBM 7014-T00 Enterprise 19" Rack Enclosure No Keys
$549.95