-
Problems with NFS-Server from Knoppix 3.7 CD
Hi,
I want to boot from my Knoppix-CD and then start up a NFS-Server and mount a directory from my Knoppix-CD
over NFS on another system.
After booting from Knoppix-CD i created a simple /etc/exports-file:
/home/knoppix *(ro,sync)
Then i started portmapper and nfs-kernel-server, which both are preinstalled on the Knoppix-CD:
Code:
/etc/init.d/portmap start
/etc/init.d/nfs-kernel-server start
Finally i tried to mount that export from the other system:
Code:
mkdir /mnt/nfs
mount -t nfs -o nolock Knoppix_IP:/home/knoppix /mnt/nfs
But all i got is this error:
Code:
mount: RPC: Unable to receive; errno = Connection refused
mount: nfsmount failed: Bad file descriptor
mount: Mounting Knoppix_IP:/home/knoppix on /mnt/nfs failed: invalid argument
I have another Knoppix-System as HD-install. Following the above steps on this system works as it should.
I tried to export different directories than /home/knoppix but that brought no success.
The filesystem of the Live-CD resides on a ramdisk. Could there be an issue with accessing directories over NFS on a ramdisk? Had anybody success starting an NFS-Server from the CD?
Thanks in advance,
karl sand
-
NFS-Server-problem solved
Finally i solved that issue by myself
Just for for anybody who runs into the same problems, here is what i did.
The problem however was an authentication issue. Both, the portmap daemon and rpc.mountd
are linked against the tcp_wrapper library. That means to get them working properly you have to
specify all allowed hosts in the /etc/hosts.allow file. By default all hosts of the local domain
should be granted access to all services. The client-system that i use is a host in the local network but
not administrated by DNS, thus its domainname is considered invalid by the tcp_wrapper.
I added the following lines to the default Knoppix /etc/hosts.allow
file:
Code:
# additional lines in /etc/hosts.allow
portmap: 192.168.2.*
mountd: 192.168.2.*
Note: You have to use the daemon names, even if the binary-names are different! 192.168.2.0/255.255.255.0 is my local network.
After doing so, everything works fine.
-
...
there is still problem.
It is not possible to use the /home/knoppix dir in my exports-file. (the same with /ramdisk/home/knoppix)
When i use the rootdir / it works, but it is still not possible to access the ramdisk over nfs.
when i mount the / on the client i can see the /ramdisk dir and can change to the dir but when
i do ls -l: it seems to contain nothing... i'm still confused...
Similar Threads
-
By giacco in forum Hardware & Booting
Replies: 3
Last Post: 01-10-2006, 10:47 PM
-
By wiccaan in forum General Support
Replies: 0
Last Post: 06-06-2005, 04:07 AM
-
By Coffee-OD in forum Hardware & Booting
Replies: 6
Last Post: 03-31-2005, 10:43 PM
-
By smartin in forum Hardware & Booting
Replies: 3
Last Post: 05-05-2004, 06:40 PM
-
By shimsham in forum General Support
Replies: 0
Last Post: 04-22-2004, 01:22 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

MegaRAID 9580-8i8e 16-port 12G SAS/SATA/NVMe 8GB PCIe RAID - 05-50076-00
$1619.30

Broadcom 9600-24i Tri-Mode RAID Controller 4.0 NVMe SAS SATA NEW 05-50111-01003
$639.69

BROADCOM 05-50077-01 PCI-E 4.0 x8 PCI-Express MegaRAID 9560-8i RAID Controller
$739.99

Intel VROC Premium RAID Controller Card PCIe Add-On Module VROCPREMMOD
$265.00

OWC Mercury Elite Pro Quad 4 Bay RAID Storage Enclosure USB 3.1 Gen 2 No Drives
$149.95

LSI 9260-8i 512MB SAS SATA 8-port PCI-E 6Gb RAID Controller Card US
$29.88

Broadcom LSI 9305-16i 12Gbps SAS-3 PCIe x8 HBA 16-Ports Raid Controller
$64.99

9300-8i LSI SAS3008 8-Port 12Gb PCIe IT mode ZFS FreeNAS unRAID 2*SFF-8643 US
$49.50

CalDigit VR minin 2 Portable Raid Storage On The Go
$75.00

Broadcom 9600-24i RAID Controller PCIe Gen 4.1 Tri-Mode NEW 05-50111-01004
$649.99