-
Problems with NFS-Server from Knoppix 3.7 CD
Hi,
I want to boot from my Knoppix-CD and then start up a NFS-Server and mount a directory from my Knoppix-CD
over NFS on another system.
After booting from Knoppix-CD i created a simple /etc/exports-file:
/home/knoppix *(ro,sync)
Then i started portmapper and nfs-kernel-server, which both are preinstalled on the Knoppix-CD:
Code:
/etc/init.d/portmap start
/etc/init.d/nfs-kernel-server start
Finally i tried to mount that export from the other system:
Code:
mkdir /mnt/nfs
mount -t nfs -o nolock Knoppix_IP:/home/knoppix /mnt/nfs
But all i got is this error:
Code:
mount: RPC: Unable to receive; errno = Connection refused
mount: nfsmount failed: Bad file descriptor
mount: Mounting Knoppix_IP:/home/knoppix on /mnt/nfs failed: invalid argument
I have another Knoppix-System as HD-install. Following the above steps on this system works as it should.
I tried to export different directories than /home/knoppix but that brought no success.
The filesystem of the Live-CD resides on a ramdisk. Could there be an issue with accessing directories over NFS on a ramdisk? Had anybody success starting an NFS-Server from the CD?
Thanks in advance,
karl sand
-
NFS-Server-problem solved
Finally i solved that issue by myself
Just for for anybody who runs into the same problems, here is what i did.
The problem however was an authentication issue. Both, the portmap daemon and rpc.mountd
are linked against the tcp_wrapper library. That means to get them working properly you have to
specify all allowed hosts in the /etc/hosts.allow file. By default all hosts of the local domain
should be granted access to all services. The client-system that i use is a host in the local network but
not administrated by DNS, thus its domainname is considered invalid by the tcp_wrapper.
I added the following lines to the default Knoppix /etc/hosts.allow
file:
Code:
# additional lines in /etc/hosts.allow
portmap: 192.168.2.*
mountd: 192.168.2.*
Note: You have to use the daemon names, even if the binary-names are different! 192.168.2.0/255.255.255.0 is my local network.
After doing so, everything works fine.
-
...
there is still problem.
It is not possible to use the /home/knoppix dir in my exports-file. (the same with /ramdisk/home/knoppix)
When i use the rootdir / it works, but it is still not possible to access the ramdisk over nfs.
when i mount the / on the client i can see the /ramdisk dir and can change to the dir but when
i do ls -l: it seems to contain nothing... i'm still confused...
Similar Threads
-
By giacco in forum Hardware & Booting
Replies: 3
Last Post: 01-10-2006, 10:47 PM
-
By wiccaan in forum General Support
Replies: 0
Last Post: 06-06-2005, 04:07 AM
-
By Coffee-OD in forum Hardware & Booting
Replies: 6
Last Post: 03-31-2005, 10:43 PM
-
By smartin in forum Hardware & Booting
Replies: 3
Last Post: 05-05-2004, 06:40 PM
-
By shimsham in forum General Support
Replies: 0
Last Post: 04-22-2004, 01:22 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

HP PROLIANT TPS-W003 MICRO- SERVER TOWER Gen 8, 16G RAM
$195.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99

Supermicro 505-2 Server
$280.00

Supermicro CSE-216 No CPU No Ram No HDD Tested & Reset
$149.99

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS
$199.00

HP Proliant MicroServer Gen8, 4.5TB, (4) HDD, EXCELLENT COND.
$625.00

Supermicro 1027GR-TSF 1U Rackmount Server 2x Xeon 2.3GHz 128GB DDR3
$219.99

Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99

Nasuni NF-50 Supermicro Server, Atom CPU C2558, @ 2.40GHz, 8GB RAM-No HDD/OS/AC
$187.50