This must be a Knoppix style install, right. I had this happen also. (see this post: http://www.knoppix.net/forum/viewtopic.php?t=14325)
The boot sequence is /etc/init.d/knoppix-autoconfig which starts everything then /etc/init.d/knoppix-hd-config shuts down then attempts to restart eth0 but is unable to. I have no idea why. I edited /etc/init.d/knoppix-hd-config commenting out the eth0 shutdown/restart bit & it worked.