The latest XAMPP was just release and has not been fully distributed to all the file mirrors. You may have downloaded a corrupt file. To check if you got a good download, try:
md5sum xampp-linux-1.4.12.tar.gz
and it should match c4565112e7fbc3cd34b1a1327d4a7fe4. If not, then you have a corrupt download.

As far as I can tell, you can not run XAMPP from a Knoppix CD. It wants to be installed to /opt, a writeable place in the filesystem. I tried an different method of installing XAMPP and I installed it to /home/knoppix/opt and it installed.
tar xvfz xampp-linux-1.4.12.tar.gz -C ./opt
I ran it with the command:
sudo ./opt/lampp/lampp start
and it failed to start.
The problem I see is that it is hardcoded to install to /opt & /opt is a read-only filesystem (it maps to the knoppix CDR). You will have to either install linux on that machine or find a way to mount a vfat or a linux partition to /opt and install it there.
I hope this helps.
James