Results 1 to 8 of 8

Thread: :?: file:/mnt/sda2 - Permission, Modify content, Error:!:

  1. #1
    Junior Member
    Join Date
    Mar 2005
    Location
    Sweden
    Posts
    7

    :?: file:/mnt/sda2 - Permission, Modify content, Error:!:

    Hi, i need to move some files on a hard disc in Knoppix, but when i do it tells me "Could not make folder /mnt/sda2/..."

    Ive tried to change the properties for the disc , permissions and then Owner Can view & modify content,
    but when i do that, i get another error "Changing the attributes of files is not supported with protocol devises."

    Ive looked for solutions in the forums and faqs but found none, please help me with this.
    Im pretty much a begginner with Knoppix so please make a easy explonation thanks.

    Thanks in advance , Simon

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    Sounds like you're just trying too hard.

    First, the compulsory warning: writing to an ntfs partition (that's copying or deleting) from Linux will almost certainly trash it. ntfs is the default filsystem for NT, Windows 2K, XP.

    On 9* Windows, no problem.

    Just click on the drive you want to mount, on the drive you want to write to just click on the actions tab and select read/write. Drag and drop, that's it!

  3. #3
    Junior Member
    Join Date
    Mar 2005
    Location
    Sweden
    Posts
    7
    Quote Originally Posted by fingers99
    Sounds like you're just trying too hard.

    First, the compulsory warning: writing to an ntfs partition (that's copying or deleting) from Linux will almost certainly trash it. ntfs is the default filsystem for NT, Windows 2K, XP.

    On 9* Windows, no problem.

    Just click on the drive you want to mount, on the drive you want to write to just click on the actions tab and select read/write. Drag and drop, that's it!
    Well, my computer doesnt work since 3 days back ... sooo >X (Windows XP usually, using Knoppix to fix error now, win xp doesnt boot)

    When im in "File Manager" and in "Devices" , u told me to
    1. Click the drive i want to mount
    I dont really understand the word mount, when i right click it says "unmount", so i guess its already mounted, and i can see the files i want to move, i dont want to move them to another hard disc, just move them to another location.
    2. On the drive you want to write, just click on the actions tab and select read/write
    Hmm... when ive selected the drive i looked for a actions tab, but found none. If i right click and hold "actions" the only things mentioned is "zip" and stuff, nothing about read/write.
    3. Drag and drop isnt that easy it seems , for me anyways >(

    I would be most gratefull if you could explain it the most simple way there is.

  4. #4
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    Sorry -- right mouse click on the icon, select actions, go to change read write mode, left click.

    Drag and drop, just like Windows (or Mac): you can "open" 2 views of the drive, find the file you want to transfer, right click on it and drag it where you want it. Otherwise, there's "move to" or cut and paste.

  5. #5
    Junior Member
    Join Date
    Mar 2005
    Location
    Sweden
    Posts
    7
    Quote Originally Posted by fingers99
    Sorry -- right mouse click on the icon, select actions, go to change read write mode, left click.
    I am really slow, sorry.. But when i am there at "Hard Disc (sda2) [/mnt/sda2]" and right click on that icon. Hold mouse over Actions, the only options avaiable is "Send per Mail", "Zip file(s)", "Zip and email file(s)".

    go to change read write mode
    Could it be that you mean Right click - Properties - Permissions - "Change view and modify" ? Cause it is there i cant change because i get that error..

    Could it be that i use Kernel 2.6 with Knoppix 3.7 ? (Without the Serial-ATA disks doesnt show )

    Drag and drop, just like Windows (or Mac): you can "open" 2 views of the drive, find the file you want to transfer, right click on it and drag it where you want it. Otherwise, there's "move to" or cut and paste.
    Drag and drop = Could not write to /mnt/sda2/... and with cut and paste = Could not delete ....


    *i have now tested with Knoppix 3.6, Kernel 2.6 (because of the SATA discs) , and the results is the same, just some small differences - when i right click and hold actions, there is 3 new options, "create gzipped tar archive", "create bzipped tar archive" and "create zip archive".. No big use huh >P*

  6. #6
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    Very, very strange. I'm using 3.6 with the 2.6 kernel but from a HD install.

    Just a thought, if you open a file manager in Super User mode:

    Kmenu>System>Other Progames>File Manager Super User Mode and go to the Desktop, do you get the same results?

  7. #7
    Junior Member
    Join Date
    Mar 2005
    Location
    Sweden
    Posts
    7
    Quote Originally Posted by fingers99
    Very, very strange. I'm using 3.6 with the 2.6 kernel but from a HD install.

    Just a thought, if you open a file manager in Super User mode:

    Kmenu>System>Other Progames>File Manager Super User Mode and go to the Desktop, do you get the same results?
    When i start that program i need to write a password, ive never entered a password so i didnt know what to do. I tested Ignore.
    The results are exactly the same. (Whitout password)

    Edited > I changed the root password with Root Shell to "root" by typing passwd, now when i used Super user mode with the new password i got it working, i belive. But still, i wasnt able to see or change the settings for read/write.

  8. #8
    Junior Member registered user
    Join Date
    Apr 2005
    Location
    Texada Is. BC Canada
    Posts
    18
    RE::"Hi, i need to move some files on a hard disc in Knoppix, but when i do it tells me "Could not make folder /mnt/sda2/.."

    Had to reply because it doesn't seem this got resolved for Simonkex. I discovered this little nasty with a Flash Card inserted into a USB port.
    To make it short:

    Plug in the Drive and wait till it pops up on your desktop.
    "Right Click" on the Drive Icon and "Mount" from the Menu that pops up.
    "Right Click" again and choose "Actions", and from the next Menu choose "Change read/write mode".
    A window will pop up asking if you really want to "change partition... to be writtable?"
    Click "Yes". (All this assumes the Drive is NOT formatted in ntfs)

    Now to verify everything is as it should be: try writing a new Directory to the drive -- if it works, you're good to go.

    I discovered the USB drives weren't automatically writable when I directed a download to one

    I've used quite a few different Distros of Linux and I really like Knoppix (almost everything works great)...
    Only time I was really ticked was when trying to save a "configuration" to floppy and discovered I couldn't
    get it to re-load on startup. The startup command was wrong in the documentation -- it should be:
    "knoppix floppyconf" NOT "knoppix myconfig=/mnt/auto/floppy"

Similar Threads

  1. Unable to modify 'system' file on windows XP HDD
    By KnoppixIsOk in forum MS Windows & New to Linux
    Replies: 5
    Last Post: 08-23-2007, 11:27 PM
  2. [newbie-need help] error while change HDD permission file
    By pai in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 04-07-2006, 09:32 PM
  3. xsane file permission
    By chiasc in forum General Support
    Replies: 0
    Last Post: 11-10-2005, 11:50 PM
  4. How I can modify a file on the hard disk!
    By Ionut in forum General Support
    Replies: 1
    Last Post: 06-21-2004, 08:05 PM
  5. File Permission ?----------
    By dabuggin1 in forum General Support
    Replies: 1
    Last Post: 02-04-2004, 08:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM picture

Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM

$1625.00



Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram  2x 550W PSU No HDD picture

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD

$275.00



Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed picture

Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed

$49.99



VMware vCenter Server 8 STANDARD Perpetual License Key VC-STD-C (Legacy Pack) picture

VMware vCenter Server 8 STANDARD Perpetual License Key VC-STD-C (Legacy Pack)

$1599.95



Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W

$409.99



Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p picture

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p

$499.88



Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD picture

Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD

$378.93



Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb picture

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb

$374.99



867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001 picture

867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001

$245.00



Dell EMC VxRail E560F 10-SFF 2*Gold 6230R 2.1GHz No RAM HBA330 iDrac Ent Server picture

Dell EMC VxRail E560F 10-SFF 2*Gold 6230R 2.1GHz No RAM HBA330 iDrac Ent Server

$349.99