I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Unlike my previously successful hard disk Knoppix installations (various versions from 3.1 to 3.4) my latest HD installation (3.8.1) does not result in root being one of the user options for selection once the boot process has finished. I can login as a normal user, and successfully su into root via a terminal window, but if I then try to start Konqueror from the command line I get the following:-
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
konqueror: cannot connect to X server :0.0
How can I run root from a KDE graphical interface using Knoppix 3.8.1, as I am used to doing using Knoppix 3.3?
The rest of the installation works fine, and I am even able to print from a network printer which previously required editing of cups and kde configuration files.
Thanks for any advice.
I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Thanks for the reply eon. Unfortunately, although the command you suggested works for localhost, it doesn't work for root for some reason. Below is some more output that may be useful for someone to explain what I need to adjust to enable a graphical root environment.
mark@z:~$ xhost + localhost
localhost being added to access control list
root@z:/home/mark# xhost + root
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
xhost: unable to open display ":0.0"
root@z:/home/mark# startx
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
X: warning; process set to priority -11 instead of requested priority -10
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to [email protected].
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.
You might want to check this thread: http://www.linuxforums.org/forum/topic-19634.html
And look at ~/.xinitrc file to see what's there or not there.
Check here, too: http://www.knoppix.net/forum/viewtop...?p=82492#82492
-- Ed
And another link: http://www.knoppix.net/forum/viewtopic.php?t=17347
There's plenty about this on this site if you search.

Samsung 2.5" 870 EVO SSD SATA III 250GB 500GB 1TB Internet Solid State Drive Lot
$100.00
Samsung 860 EVO 250GB SSD MZ-76E250 2.5" SATA III Solid State Drive -
$36.99
Netac 120GB 256GB 1TB 2TB Internal SSD 2.5'' SATAIII 6Gb/s Solid State Drive lot
$119.99
Western Digital Blue 3D NAND 500GB Internal 2.5" SSD - WDS500G2B0A
$49.99
Fanxiang 256GB 512GB 1TB 2TB 4TB SSD Lot 2.5'' SATA Internal Solid State Drive
$42.99
Fanxiang 1/2/5/10Pcs 2.5'' SATA SSD Lot 1TB 2TB 4TB 512GB 256GB TLC Internal SSD
$129.99
2 PACK 128 GB SSD M.2 2280 SATA Solid State Drive Major Brands, Samsung, LiteON
$28.00
Netac 2TB 1TB 512GB 256GB Internal SSD 2.5inch SATAIII Solid State Drive lot
$259.00
Intel Solid-State Drive DC S3500 Series 240GB Internal 2.5" (SSDSC2BB240G4P) SSD
$29.99
Netac 1TB 512GB 256GB Internal SSD 2.5inch SATA Solid State Drive lot PC Laptop
$221.00