I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Unlike my previously successful hard disk Knoppix installations (various versions from 3.1 to 3.4) my latest HD installation (3.8.1) does not result in root being one of the user options for selection once the boot process has finished. I can login as a normal user, and successfully su into root via a terminal window, but if I then try to start Konqueror from the command line I get the following:-
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
konqueror: cannot connect to X server :0.0
How can I run root from a KDE graphical interface using Knoppix 3.8.1, as I am used to doing using Knoppix 3.3?
The rest of the installation works fine, and I am even able to print from a network printer which previously required editing of cups and kde configuration files.
Thanks for any advice.
I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Thanks for the reply eon. Unfortunately, although the command you suggested works for localhost, it doesn't work for root for some reason. Below is some more output that may be useful for someone to explain what I need to adjust to enable a graphical root environment.
mark@z:~$ xhost + localhost
localhost being added to access control list
root@z:/home/mark# xhost + root
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
xhost: unable to open display ":0.0"
root@z:/home/mark# startx
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
X: warning; process set to priority -11 instead of requested priority -10
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to [email protected].
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.
You might want to check this thread: http://www.linuxforums.org/forum/topic-19634.html
And look at ~/.xinitrc file to see what's there or not there.
Check here, too: http://www.knoppix.net/forum/viewtop...?p=82492#82492
-- Ed
And another link: http://www.knoppix.net/forum/viewtopic.php?t=17347
There's plenty about this on this site if you search.

Kingston 32GB 64GB 128GB 256GB USB 3.0 Flash Drive Thumb Memory Stick Pen lot
$285.90
LOT OF 2 Micron 16GB 2Rx8 PC4-2666V-EE1-11 P/N: MTA18ASF2G72AZ-2G6D1ZG
$199.95
x6 SK Hynix 8GB 1Rx4 PC4-2133P DDR4 17000 ECC Memory HMA41GR7AFR4N-TF
$170.00
Lot Of 8 Micron 8GB 2Rx8 PC4-2666V-RE2-11 ECC REG Server Ram MTA18ASF1G72PDZ-2G6
$210.00
USB 3.0 Flash Drive 32GB 64GB 128GB Memory Stick Thumb Stick Lot Pack
$826.09
Lot of 3~BAD~NON-WORKING Micron 64GB 4DRx4 PC4-2666V-LE2 Server RAM Memory DDR4
$600.00
LOT OF 6 Samsung 64GB 4DRx4 PC4-2666V M386A8K40BM2-CTD6Q Server RAM
$1799.99
Lot of 2~BAD~NON-WORKING Micron 64GB 2Rx4 PC4-2933Y-RB3 Server RAM Memory DDR4
$400.00
LOT OF 2 SK Hynix 8GB 1Rx8 PC4-3200AA ECC HMA81GR7CJR8N-XN
$89.95
LOT OF 4 Samsung 16GB DDR4-2666 ECC UDIMM 2Rx8 PC4-21300 M391A2K43BB1-CTDQ
$469.95