I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Unlike my previously successful hard disk Knoppix installations (various versions from 3.1 to 3.4) my latest HD installation (3.8.1) does not result in root being one of the user options for selection once the boot process has finished. I can login as a normal user, and successfully su into root via a terminal window, but if I then try to start Konqueror from the command line I get the following:-
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
konqueror: cannot connect to X server :0.0
How can I run root from a KDE graphical interface using Knoppix 3.8.1, as I am used to doing using Knoppix 3.3?
The rest of the installation works fine, and I am even able to print from a network printer which previously required editing of cups and kde configuration files.
Thanks for any advice.
I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Thanks for the reply eon. Unfortunately, although the command you suggested works for localhost, it doesn't work for root for some reason. Below is some more output that may be useful for someone to explain what I need to adjust to enable a graphical root environment.
mark@z:~$ xhost + localhost
localhost being added to access control list
root@z:/home/mark# xhost + root
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
xhost: unable to open display ":0.0"
root@z:/home/mark# startx
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
X: warning; process set to priority -11 instead of requested priority -10
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to [email protected].
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.
You might want to check this thread: http://www.linuxforums.org/forum/topic-19634.html
And look at ~/.xinitrc file to see what's there or not there.
Check here, too: http://www.knoppix.net/forum/viewtop...?p=82492#82492
-- Ed
And another link: http://www.knoppix.net/forum/viewtopic.php?t=17347
There's plenty about this on this site if you search.

Netac DDR4 32GB 16GB DDR4 3200MHz UDIMM C16 Desktop Internal Memory RAM Kit
$99.99
Lot of 88GB (22x4GB) ADVANTECH 1RX16 DDR4 PC4-2400U AQD-D4U4GN24-HP MEMORY RAM
$286.00
A-Tech 8GB DDR3 1600 PC3-12800 Laptop SODIMM 204-Pin Memory RAM PC3L DDR3L 1x 8G
$21.68
Major Brand 16GB (2x8GB) PC3-12800U DDR3-1600MHz DDR3-12800 DESKTOP RAM NON-ECC
$29.99
Grade A Micron Cisco 64GB PC4-3200AA DDR4 2Rx4 RDIMM RAM MTA36ASF8G72PZ-3G2 LOT
$599.99
Lot of 3~BAD~NON-WORKING Micron 64GB 4DRx4 PC4-2666V-LE2 Server RAM Memory DDR4
$600.00
LOT OF 4 Samsung 16GB DDR4-2666 ECC UDIMM 2Rx8 PC4-21300 M391A2K43BB1-CTDQ
$469.95
Crucial DDR3L 16GB 2 x 8GB 1600 MHz PC3L-12800 Laptop RAM Sodimm Memory 1.35V
$41.00
Micron 32GB 1x32GB DDR5 5600 CL46 ECC Unbuffered SO-DIMM MTC20C2085S1TC56BD1
$399.00
RAMAXEL Lenovo 32GB LPDDR5X CAMM2 7500MHz Laptop RAM | UNTESTED
$445.00