I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Unlike my previously successful hard disk Knoppix installations (various versions from 3.1 to 3.4) my latest HD installation (3.8.1) does not result in root being one of the user options for selection once the boot process has finished. I can login as a normal user, and successfully su into root via a terminal window, but if I then try to start Konqueror from the command line I get the following:-
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
konqueror: cannot connect to X server :0.0
How can I run root from a KDE graphical interface using Knoppix 3.8.1, as I am used to doing using Knoppix 3.3?
The rest of the installation works fine, and I am even able to print from a network printer which previously required editing of cups and kde configuration files.
Thanks for any advice.
I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Thanks for the reply eon. Unfortunately, although the command you suggested works for localhost, it doesn't work for root for some reason. Below is some more output that may be useful for someone to explain what I need to adjust to enable a graphical root environment.
mark@z:~$ xhost + localhost
localhost being added to access control list
root@z:/home/mark# xhost + root
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
xhost: unable to open display ":0.0"
root@z:/home/mark# startx
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
X: warning; process set to priority -11 instead of requested priority -10
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to [email protected].
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.
You might want to check this thread: http://www.linuxforums.org/forum/topic-19634.html
And look at ~/.xinitrc file to see what's there or not there.
Check here, too: http://www.knoppix.net/forum/viewtop...?p=82492#82492
-- Ed
And another link: http://www.knoppix.net/forum/viewtopic.php?t=17347
There's plenty about this on this site if you search.

GIGABYTE A520M DS3H AC AMD AM4 Motherboard mATX
$59.99
GIGABYTE Z790 AORUS ELITE AX LGA 1700 Intel Z790 ATX Motherboard with DDR5
$189.99
Intel H310 LGA1151 8-9th Gen DDR4 M.2 NVMe mATX Motherboard IO Shield Battery
$54.99
ASUS PRIME Z890-P WIFI Z890 LGA 1851 ATX motherboard, Intel® Core™ Ultra Series
$235.99
ASUS PRIME B360M-C MicroATX Intel LGA1151 DDR4 HDMI VGA USB RJ-45 Audio
$34.99
GIGABYTE B365 HD3 LGA1151 Intel 9th Gen motherboard
$59.99
MSI B550M PRO-VDH Micro-ATX Motherboard - AMD AM4, Ryzen 5000/4000/3000 Ready, P
$71.49
MSI - B550M PRO-VDH WIFI (Socket AM4) AMD B550 MATX DDR4 Wi-Fi 6 Motherboard ...
$89.99
ASUS PRIME Z490-V Motherboard Intel Z490 10th gen DDR4 LGA 1200 ATX w/ IO Shield
$84.99
ASRock IMB-X1314 LGA 1700 Intel W680 DDR4 Quad display Micro-ATX Motherboard
$351.99