Thanks for the reply eon. Unfortunately, although the command you suggested works for localhost, it doesn't work for root for some reason. Below is some more output that may be useful for someone to explain what I need to adjust to enable a graphical root environment.

mark@z:~$ xhost + localhost
localhost being added to access control list

root@z:/home/mark# xhost + root
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

xhost: unable to open display ":0.0"
root@z:/home/mark# startx
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority

X: warning; process set to priority -11 instead of requested priority -10

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to [email protected].

Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.