I unfortunatly get error messages when I try that - when it tries to run emu10k1.o I get "init_module: no such device". Then insmod fails, and it suggests I look through the output from dmesg and that the failure is due to a IO or a IRQ error. I believe that the relavant bit of the output from dmesg is:

Partition check:
hda: hda1
hdd:<3>ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
ldm_validate_partition_table(): Disk read failed.
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
unable to read partition table
....
NTFS driver v1.1.22 [Flags: R/W MODULE]
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
...
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0
FAT: unable to read boot sector
EFS: 1.0a - http://aeschi.ch.eu.org/efs/
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0
EFS: cannot read volume header
hdd : bad access: block=0, count=8
end_request: I/O error, dev 16:40 (hdd), sector 0
hdd : bad access: block=1, count=7
end_request: I/O error, dev 16:40 (hdd), sector 1
hdd : bad access: block=2, count=6
end_request: I/O error, dev 16:40 (hdd), sector 2
hdd : bad access: block=3, count=5
end_request: I/O error, dev 16:40 (hdd), sector 3
hdd : bad access: block=4, count=4
end_request: I/O error, dev 16:40 (hdd), sector 4
hdd : bad access: block=5, count=3
end_request: I/O error, dev 16:40 (hdd), sector 5
hdd : bad access: block=6, count=2
end_request: I/O error, dev 16:40 (hdd), sector 6
hdd : bad access: block=7, count=1
end_request: I/O error, dev 16:40 (hdd), sector 7
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0
FAT: unable to read boot sector
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0


hda1 is a NTFS Windows XP Pro disk. I might be missing something obvious, but I don't see why this should make a difference - I have a permanent home set up on a ZIP disk and so there shouldn't be any reason at all to try and go to hda1, should there? I appreciate any help

EDIT: Sorry, there was a bit more in the file that was relavant. Added. Also, the emu10k1 driver appears to be loaded already

Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
spurious 8259A interrupt: IRQ7.
Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
...
Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003


If it's easier, I'll just upload the relavant files.