Results 1 to 10 of 10

Thread: Soundcard woes...

  1. #1
    Junior Member
    Join Date
    Apr 2003
    Posts
    6

    Soundcard woes...

    I have a Soundblaster Audigy card, and after some searching on the forums, I can see that it is not currently supported although it is correctly detected on boot. However, I could not see if it is possible to install drivers after booting knoppix and then saving the configuration so that each time knoppix is booted, the Audigy card is correctly supported. Is it possible?

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Do a:
    modprobe emu10k1
    See if that gets your audigy working.

  3. #3
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    Thank you - I'll try that as soon as I can.

  4. #4
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    I unfortunatly get error messages when I try that - when it tries to run emu10k1.o I get "init_module: no such device". Then insmod fails, and it suggests I look through the output from dmesg and that the failure is due to a IO or a IRQ error. I believe that the relavant bit of the output from dmesg is:

    Partition check:
    hda: hda1
    hdd:<3>ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    ldm_validate_partition_table(): Disk read failed.
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    unable to read partition table
    ....
    NTFS driver v1.1.22 [Flags: R/W MODULE]
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    ...
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0
    FAT: unable to read boot sector
    EFS: 1.0a - http://aeschi.ch.eu.org/efs/
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0
    EFS: cannot read volume header
    hdd : bad access: block=0, count=8
    end_request: I/O error, dev 16:40 (hdd), sector 0
    hdd : bad access: block=1, count=7
    end_request: I/O error, dev 16:40 (hdd), sector 1
    hdd : bad access: block=2, count=6
    end_request: I/O error, dev 16:40 (hdd), sector 2
    hdd : bad access: block=3, count=5
    end_request: I/O error, dev 16:40 (hdd), sector 3
    hdd : bad access: block=4, count=4
    end_request: I/O error, dev 16:40 (hdd), sector 4
    hdd : bad access: block=5, count=3
    end_request: I/O error, dev 16:40 (hdd), sector 5
    hdd : bad access: block=6, count=2
    end_request: I/O error, dev 16:40 (hdd), sector 6
    hdd : bad access: block=7, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 7
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0
    FAT: unable to read boot sector
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0


    hda1 is a NTFS Windows XP Pro disk. I might be missing something obvious, but I don't see why this should make a difference - I have a permanent home set up on a ZIP disk and so there shouldn't be any reason at all to try and go to hda1, should there? I appreciate any help

    EDIT: Sorry, there was a bit more in the file that was relavant. Added. Also, the emu10k1 driver appears to be loaded already

    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
    spurious 8259A interrupt: IRQ7.
    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
    ...
    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003


    If it's easier, I'll just upload the relavant files.

  5. #5
    Senior Member registered user
    Join Date
    Jan 2003
    Location
    Podunk, Idaho, USA
    Posts
    470
    All of those error messages are referring to hdd (I would assume the CD-Rom you are running from) I think that you have a bad CD.

    rock

  6. #6
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    I redownloaded Knoppix after a MD5 check on my old iso failed. It passed the MD5 check and I burnt it. However, I'm still getting the error messages when I try to modprobe emu10k1 and dmesg gives me the same errors.

  7. #7
    Junior Member registered user
    Join Date
    Apr 2003
    Location
    Rio Rancho, NM
    Posts
    16
    Quote Originally Posted by konsole
    modknoppix@ttyp1[knoppix]$ modprobe emu10k1
    /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o: create_module: Operation not permitted
    /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o: insmod /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o failed
    /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o: insmod emu10k1 failed
    knoppix@ttyp1[knoppix]$
    You have to be logged in as root, no?
    As most of you can imagine, I'm on the CD Knoppix, and I was told that if you lock the terminal or try and log in as root, you can't because there's no pasword set or...something.

    Assistance?

  8. #8
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Quote Originally Posted by VxJasonxV
    You have to be logged in as root, no?
    As most of you can imagine, I'm on the CD Knoppix, and I was told that if you lock the terminal or try and log in as root, you can't because there's no pasword set or...something.

    Assistance?
    http://www.knoppix.net/docs/index.php/FaqUsing

  9. #9
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    I'm fairly sure that I've logged in as root, and yet I'm still getting those error messages

  10. #10
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Germany
    Posts
    297
    Quote Originally Posted by area
    I'm fairly sure that I've logged in as root, and yet I'm still getting those error messages
    Audigy works with alsa.

    See in changelog since when alsa is supported. Then start with: "knoppix alsa"

    cu

    Fabian

Similar Threads

  1. Woes Using CDs
    By A. Jorge Garcia in forum Hdd Install / Debian / Apt
    Replies: 10
    Last Post: 07-31-2005, 03:03 PM
  2. Apt-get woes
    By Shadda in forum Networking
    Replies: 1
    Last Post: 02-12-2005, 04:45 PM
  3. hd install woes
    By maul in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 07-13-2004, 01:56 PM
  4. ssh woes!!!
    By A. Jorge Garcia in forum General Support
    Replies: 4
    Last Post: 11-22-2003, 01:02 AM
  5. installation woes
    By sub_netter in forum Hardware & Booting
    Replies: 3
    Last Post: 04-02-2003, 08:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


KNOPPIX 9.1 Linux Install & Live DVD 32bit & 64bit picture

KNOPPIX 9.1 Linux Install & Live DVD 32bit & 64bit

$19.99



Windows XP, Vista, 8.1, Linux Knoppix, Office XP,  (6 CDS) picture

Windows XP, Vista, 8.1, Linux Knoppix, Office XP, (6 CDS)

$10.00



Knoppix Live GNU Linux System 9.1 on Bootable CD / DVD / USB Flash Drive picture

Knoppix Live GNU Linux System 9.1 on Bootable CD / DVD / USB Flash Drive

$10.99



KNOPPIX USB DVD OS , BEST OF ALL HIGHLY RECOMENDED picture

KNOPPIX USB DVD OS , BEST OF ALL HIGHLY RECOMENDED

$11.99



Knoppix Linux Bootable OS v8.6

Knoppix Linux Bootable OS v8.6 "Original Live Operating System" 16G USB Stick

$20.85



VINTAGE SOFTWARE | KNOPPIX STD 0.1 (SECURITY TOOLS DISTRIBUTION) picture

VINTAGE SOFTWARE | KNOPPIX STD 0.1 (SECURITY TOOLS DISTRIBUTION)

$7.57



Knoppix Linux Bootable OS v8.6

Knoppix Linux Bootable OS v8.6 "Original Live Operating System" 32G USB Stick

$21.42



Knoppix NSM 1.2 picture

Knoppix NSM 1.2

$8.00



Hamshack Live DVD-ROM picture

Hamshack Live DVD-ROM

$7.00



Knoppix 5.0.1 ULTRA RARE Linux DVD - Linux Pro Extra August 2006 picture

Knoppix 5.0.1 ULTRA RARE Linux DVD - Linux Pro Extra August 2006

$33.75