Do a:
modprobe emu10k1
See if that gets your audigy working.
I have a Soundblaster Audigy card, and after some searching on the forums, I can see that it is not currently supported although it is correctly detected on boot. However, I could not see if it is possible to install drivers after booting knoppix and then saving the configuration so that each time knoppix is booted, the Audigy card is correctly supported. Is it possible?
Do a:
modprobe emu10k1
See if that gets your audigy working.
Thank you - I'll try that as soon as I can.
I unfortunatly get error messages when I try that - when it tries to run emu10k1.o I get "init_module: no such device". Then insmod fails, and it suggests I look through the output from dmesg and that the failure is due to a IO or a IRQ error. I believe that the relavant bit of the output from dmesg is:
Partition check:
hda: hda1
hdd:<3>ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
ldm_validate_partition_table(): Disk read failed.
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
unable to read partition table
....
NTFS driver v1.1.22 [Flags: R/W MODULE]
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
...
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 2
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 4
ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 6
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0
FAT: unable to read boot sector
EFS: 1.0a - http://aeschi.ch.eu.org/efs/
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0
EFS: cannot read volume header
hdd : bad access: block=0, count=8
end_request: I/O error, dev 16:40 (hdd), sector 0
hdd : bad access: block=1, count=7
end_request: I/O error, dev 16:40 (hdd), sector 1
hdd : bad access: block=2, count=6
end_request: I/O error, dev 16:40 (hdd), sector 2
hdd : bad access: block=3, count=5
end_request: I/O error, dev 16:40 (hdd), sector 3
hdd : bad access: block=4, count=4
end_request: I/O error, dev 16:40 (hdd), sector 4
hdd : bad access: block=5, count=3
end_request: I/O error, dev 16:40 (hdd), sector 5
hdd : bad access: block=6, count=2
end_request: I/O error, dev 16:40 (hdd), sector 6
hdd : bad access: block=7, count=1
end_request: I/O error, dev 16:40 (hdd), sector 7
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0
FAT: unable to read boot sector
hdd : bad access: block=0, count=1
end_request: I/O error, dev 16:40 (hdd), sector 0
hda1 is a NTFS Windows XP Pro disk. I might be missing something obvious, but I don't see why this should make a difference - I have a permanent home set up on a ZIP disk and so there shouldn't be any reason at all to try and go to hda1, should there? I appreciate any help
EDIT: Sorry, there was a bit more in the file that was relavant. Added. Also, the emu10k1 driver appears to be loaded already
Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
spurious 8259A interrupt: IRQ7.
Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
...
Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
If it's easier, I'll just upload the relavant files.
All of those error messages are referring to hdd (I would assume the CD-Rom you are running from) I think that you have a bad CD.
rock
I redownloaded Knoppix after a MD5 check on my old iso failed. It passed the MD5 check and I burnt it. However, I'm still getting the error messages when I try to modprobe emu10k1 and dmesg gives me the same errors.
You have to be logged in as root, no?Originally Posted by konsole
As most of you can imagine, I'm on the CD Knoppix, and I was told that if you lock the terminal or try and log in as root, you can't because there's no pasword set or...something.
Assistance?
http://www.knoppix.net/docs/index.php/FaqUsingOriginally Posted by VxJasonxV
I'm fairly sure that I've logged in as root, and yet I'm still getting those error messages![]()
Audigy works with alsa.Originally Posted by area
See in changelog since when alsa is supported. Then start with: "knoppix alsa"
cu
Fabian

OPNsense pfSense 8-Core Atom C3758 2.2GHz 8GB DDR4 64GB SSD 8x NIC QAT AES VPN
$115.00
BOSGAME E4 Air Mini PC, AMD Ryzen 5 3500U 8GB DDR4 256GB SATA SSD
$169.99
Ubuntu Server 26.04.1 LTS Bootable USB Flash Drive – Latest September 2026
$12.99
VA Linux 1120 1U Rackmount Server
$100.00
OPNsense Firewall VPN QAT 8-Core Atom C3758 2.20GHz 16GB DDR4 128GB SSD 8xNIC
$175.00
Dell SonicWall TZ400 Network Security Appliance Firewall New
$295.00
All New Ubuntu 26.04 LTS Linux Bootable USB Flash Drive
$15.95
Start9 Server Pure 32GB 4TB Intel i7 Node StartOS — Box + PSU
$649.00
SQL Server 2022 Enterprise 96 Core License & DVD Unlimited CALs with CoA
$284.99
Sun Enterprise e450 400mhz cpu(x4), 4gb ram, 9gb HD w/spud most complete on ebay
$500.00