install unionfs-utils from debian
I'm doing a remastering with 3.9 version and would like to replace buggy unionfs version (052605-1143) with stable 1.0.11-1 version.
I can remove unionfs-module-2.6.11 with apt but also knoppix-image is removed at the same time. Then I can install unionfs-source and unionfs-utils with apt but not knoppix-image.
Now the situation is that I have a working UNIONFS but can't choose 'create a persistent KNOPPIX disk image' from Knoppix menu, and the former created disk image is not recognized.
How to get knoppix-image installed back? Is there an apt repository somewhere where it could be installed with apt?
-tapsa-
install unionfs-utils from debian
I found solution in an other tread:
I had Knoppix 3.8.1 and got package knoppix-image_0.5-8_i386.deb from it with dpkg-repack. Then I installed it:Code:dpkg-repack knoppix-image
Now the case is closed!Code:dpkg -i knoppix-image_0.5-8_i386.deb
-tapsa-
But now possibly you have doungraded knoppix-image
Yes, you are right. I think knoppix-image from Knoppix 3.9 can also be used. SoOriginally Posted by Sergey.Khlutchin
in Knoppix 3.9 gives knoppix-image_0.5-9_i386.debCode:dpkg-repack knoppix-image
-tapsa-
Did this solution solve the problem for you?
Yes and no. Now knoppix-image works but KDE does not start.Originally Posted by knopx4me
This is a littlle bit out of topic but I get this in my /home/knoppix/.xsession-errors:
After this twm starts and gives error message of ksmserver which could not be started.Code:/etc/X11/Xsession.d/45xsession: line 73: [: : integer expression expected /etc/X11/Xsession.d/45xsession: line 77: [: : integer expression expected SocketCreateListener: failed to bind listener SocketUNIXCreateListener: ...SocketCreateListener() failed MakeAllCOTSServerListeners: failed to create listener for local Cannot establish any listening sockets DCOPServer self-test failed. kdeinit: DCOPServer could not be started, aborting. Warning: connect() failed: : Connection refused SocketCreateListener: failed to bind listener SocketUNIXCreateListener: ...SocketCreateListener() failed MakeAllCOTSServerListeners: failed to create listener for local Cannot establish any listening sockets DCOPServer self-test failed. kdeinit: DCOPServer could not be started, aborting.
This is at least fifth time I try to remaster Knoppix 3.9. This time I made a brand new remastering and used only stable and testing packages in updating (changed default-release to sarge and commented unstable out from sources.list). Only KDE 3.4.1 is experimental.
But I can't understand whyI can start X from my chrooted remastering partition ('su - knoppix' and 'startx'). Anyhow, I got error message of DCOpServer that is already running but KDE starts and everything works. But why do they not work after doing a compressed fs and isofs?
I hope that someone could tell me what those error messages mean and how to get rid of them.
I have used menu based scripts in my remastering.
-tapsa-
Did you do the following while chrooted:
chmod 777 /tmp
But anyway, the reason I asked you if it did work is that I have tried to remaster it several times after downgrading UnionFS, but failed so I gave up and remastered Kanotix instead.
No need for that anymore because in knoppix-autoconfig is line 524:Originally Posted by knopx4me
So it is right by default. And as I said before, I can startx X in chrooted state fine.Code:chmod 1777 /tmp 2>/dev/null
But when I do compressed fs and isofs, I can boot to text mode (boot: linux 2) but not in X. If I try to change to graphical mode by init 5, I get errors. Why can't I start DCOPServer here (booting my new remastering) but can start it there (chrooted)?
One thing more. I can start an other X in my working remastering (from Knoppix 3.8.1) by su - knoppix and startx -- :2 (starts X to an other virtual terminal). It is the same as starting X in chrooted state. But in my new remastering (Knoppix 3.9). I get X: user not authorized to run the X server, aborting. Why do I have no permissions to run X server? In spite of that /home/knoppix is populated right.
Anyhow, I'm not giving up. There must be a solution somewhere. But I don't know KDE's starting process enough, so it's difficult to figure out what is not right. I think that knoppix-autoconfig is right because I can boot to text mode fine.
So is the problem in 45xsession or in kdeinit which starts dcopserver? Perhaps someone could help me.
I have also noticed that reversing back to stable UnionFS didn't help. Sometimes my whole machine is halted perfectly in spite of that. Perhaps the problem in Knoppix 3.9 has been kdeinit and not UnionFS .
-tapsa-

OPNsense pfSense 8-Core Atom C3758 2.2GHz 8GB DDR4 64GB SSD 8x NIC QAT AES VPN
$115.00
Microsoft SQL Server 2019 Enterprise 40 Core Unlimited CAL Retail License FPP
$299.00
OPNsense Firewall VPN QAT 8-Core Atom C3758 2.20GHz 16GB DDR4 128GB SSD 8xNIC
$175.00
Ubuntu Server 26.04.1 LTS Bootable USB Flash Drive – Latest September 2026
$12.99
Start9 Server Pure 32GB 4TB Intel i7 Node StartOS — Box + PSU
$649.00
ZimaBoard 2 1664 Home Server 16GB
$350.00
Novell SUSE Linux Enterprise Server 9, Linux Professional 8.2 / 9.1 — 3 DVD Set
$58.00
All New Ubuntu 26.04 LTS Linux Bootable USB Flash Drive
$15.95
SQL Server 2022 Enterprise 96 Core License & DVD Unlimited CALs with CoA
$284.99
Red Hat Enterprise Linux 5 Server DVD English OS Media Kit RHF0382US
$41.30