I had the same experience. The terminal server works great when the server is running off of the CD, but the client cannot fails to mount when the server is running Knoppix from the hard drive.

I played with the settings for a day or two and gave up. But I would like to know how to resolve the issue. I just have too many irons in the fire to figure it out myself.