-
mysql on startup
Hi All,
I've created a remastered version of Knoppix 3.9 with apache, php and mysql 4.1 . I'm having a strange problem on startup, Apache starts up OK but when I try to startup mysql it requires four commands (one at boot time) before it will actually start up i.e.
TRY 1
root@0[~]# /etc/init.d/mysql start
Starting MySQL database server: mysqld...failed.
Please take a look at the syslog.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
TRY 2
root@0[~]# /etc/init.d/mysql start
Starting MySQL database server: mysqld...failed.
Please take a look at the syslog.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
TRY 3
root@0[~]# /etc/init.d/mysql start
Starting MySQL database server: mysqld.
Checking for crashed MySQL tables in the background.
root@0[~]#
Then mysql starts OK
with mysqld I get
TRY 1
root@1[~]# mysqld
InnoDB: Unable to lock ./ib_logfile0, error: 9
InnoDB: Error in opening ./ib_logfile0
050819 11:40:59 [ERROR] Can't init databases
050819 11:40:59 [ERROR] Aborting
050819 11:41:00 [Note] mysqld: Shutdown complete
TRY 2
root@1[~]# mysqld
InnoDB: Unable to lock ./ib_logfile1, error: 9
InnoDB: Error in opening ./ib_logfile1
050819 11:41:06 [ERROR] Can't init databases
050819 11:41:06 [ERROR] Aborting
050819 11:41:07 [Note] mysqld: Shutdown complete
TRY 3
root@1[~]# mysqld
050819 11:41:11 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
050819 11:41:13 InnoDB: Starting log scan based on checkpoint at
InnoDB: log sequence number 0 43782.
InnoDB: Doing recovery: scanned up to log sequence number 0 43782
InnoDB: Last MySQL binlog file position 0 79, file name /var/log/mysql/mysql-bin.000010
050819 11:41:13 InnoDB: Flushing modified pages from the buffer pool...
050819 11:41:13 InnoDB: Started; log sequence number 0 43782
mysqld: ready for connections.
Version: '4.1.11-Debian_4-log' socket: '/var/run/mysqld/mysqld.sock' port: 3306 Source distribution
mysql start OK
I managed to overcome the problem on startup by having 4 startup scripts, but this extends the startup time by quite a bit so I would like to find a better fix. Has anyone seen this before or know of a fix.
Thanks
-
Junior Member
registered user
I did the mysql start like this:
in /KNOPPIX/knoppix.sh I added
/etc/init.d/mysql stop
chown -R mysql:mysql /var/lib/mysql
chmod ugo+rwx /var/lib/mysql/*
chmod -R ugo+rw /var/lib/mysql
touch /var/log/mysql/mysql.log
chown mysql:adm /var/log/mysql/mysql.log
sleep 5
/etc/init.d/mysql start
cat /cdrom/[MyFolder]/sqldb.sql | /usr/bin/mysql -p[TheRootPasswd]
-
Thanks for the reply, is it a permissions problem then. If so, how come it starts up after a few tries?
-
Senior Member
registered user
mysqld_safe may be useful for you to start mysql
see
http://dev.mysql.com/doc/mysql/en/mysqld-safe.html
In the past I used
rm -rf /var/lib/mysql
cp -rp /KNOPPIX/var/lib/mysql /var/lib
mysqld_safe &
which worked for Knoppix 3.3, but whether it works for 3.9 I don't know.
The p option to the cp command preserves permissions.
Regards,
Mark
Similar Threads
-
By seballa in forum Hdd Install / Debian / Apt
Replies: 0
Last Post: 06-08-2009, 04:47 PM
-
By kjackson7_93 in forum General Support
Replies: 12
Last Post: 02-03-2007, 11:39 PM
-
By jagodragon in forum General Support
Replies: 0
Last Post: 12-11-2006, 03:34 AM
-
By Coume in forum General Support
Replies: 5
Last Post: 08-06-2003, 06:42 AM
-
By Terry@nz in forum General Support
Replies: 3
Last Post: 06-09-2003, 10:01 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

5 Port Gigabit Unmanaged Ethernet Switch, Home Network Hub, Office Ethernet S...
$9.64

NETGEAR GS308EP Essential Series 8-Port Gigabit PoE+ Unmanaged Switch
$49.99

D-Link DGS-1210-28P 28-Port PoE Gigabit Web Smart Switch With Cord
$49.99

Cisco Catalyst 2960-48TT-L 48-Port Fast Ethernet Managed Rackmount Switch
$46.99

TP-Link TL-SG105 5-Port Gigabit Ethernet Unmanaged Metal Desktop Network Switch
$19.99

10-Port Gigabit PoE Network Switch with 8 PoE+ Ports with 2 Combo SFP Slots 125W
$39.99

TP-Link TL-SG105, 5 Port Gigabit Unmanaged Ethernet Switch, Network Hub, Ethern
$15.25

Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch with rack mounts
$69.00

5Ports Gigabit Network Switch w/ 4 PoE+ Ports Total 52W each port 30W Plug&Play
$31.99

Linksys LGS328MPC 24-Port Managed Gigabit PoE+ Switch with 4 10G SFP+ Uplinks
$224.95