-
mysql on startup
Hi All,
I've created a remastered version of Knoppix 3.9 with apache, php and mysql 4.1 . I'm having a strange problem on startup, Apache starts up OK but when I try to startup mysql it requires four commands (one at boot time) before it will actually start up i.e.
TRY 1
root@0[~]# /etc/init.d/mysql start
Starting MySQL database server: mysqld...failed.
Please take a look at the syslog.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
TRY 2
root@0[~]# /etc/init.d/mysql start
Starting MySQL database server: mysqld...failed.
Please take a look at the syslog.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
TRY 3
root@0[~]# /etc/init.d/mysql start
Starting MySQL database server: mysqld.
Checking for crashed MySQL tables in the background.
root@0[~]#
Then mysql starts OK
with mysqld I get
TRY 1
root@1[~]# mysqld
InnoDB: Unable to lock ./ib_logfile0, error: 9
InnoDB: Error in opening ./ib_logfile0
050819 11:40:59 [ERROR] Can't init databases
050819 11:40:59 [ERROR] Aborting
050819 11:41:00 [Note] mysqld: Shutdown complete
TRY 2
root@1[~]# mysqld
InnoDB: Unable to lock ./ib_logfile1, error: 9
InnoDB: Error in opening ./ib_logfile1
050819 11:41:06 [ERROR] Can't init databases
050819 11:41:06 [ERROR] Aborting
050819 11:41:07 [Note] mysqld: Shutdown complete
TRY 3
root@1[~]# mysqld
050819 11:41:11 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
050819 11:41:13 InnoDB: Starting log scan based on checkpoint at
InnoDB: log sequence number 0 43782.
InnoDB: Doing recovery: scanned up to log sequence number 0 43782
InnoDB: Last MySQL binlog file position 0 79, file name /var/log/mysql/mysql-bin.000010
050819 11:41:13 InnoDB: Flushing modified pages from the buffer pool...
050819 11:41:13 InnoDB: Started; log sequence number 0 43782
mysqld: ready for connections.
Version: '4.1.11-Debian_4-log' socket: '/var/run/mysqld/mysqld.sock' port: 3306 Source distribution
mysql start OK
I managed to overcome the problem on startup by having 4 startup scripts, but this extends the startup time by quite a bit so I would like to find a better fix. Has anyone seen this before or know of a fix.
Thanks
-
Junior Member
registered user
I did the mysql start like this:
in /KNOPPIX/knoppix.sh I added
/etc/init.d/mysql stop
chown -R mysql:mysql /var/lib/mysql
chmod ugo+rwx /var/lib/mysql/*
chmod -R ugo+rw /var/lib/mysql
touch /var/log/mysql/mysql.log
chown mysql:adm /var/log/mysql/mysql.log
sleep 5
/etc/init.d/mysql start
cat /cdrom/[MyFolder]/sqldb.sql | /usr/bin/mysql -p[TheRootPasswd]
-
Thanks for the reply, is it a permissions problem then. If so, how come it starts up after a few tries?
-
Senior Member
registered user
mysqld_safe may be useful for you to start mysql
see
http://dev.mysql.com/doc/mysql/en/mysqld-safe.html
In the past I used
rm -rf /var/lib/mysql
cp -rp /KNOPPIX/var/lib/mysql /var/lib
mysqld_safe &
which worked for Knoppix 3.3, but whether it works for 3.9 I don't know.
The p option to the cp command preserves permissions.
Regards,
Mark
Similar Threads
-
By seballa in forum Hdd Install / Debian / Apt
Replies: 0
Last Post: 06-08-2009, 04:47 PM
-
By kjackson7_93 in forum General Support
Replies: 12
Last Post: 02-03-2007, 11:39 PM
-
By jagodragon in forum General Support
Replies: 0
Last Post: 12-11-2006, 03:34 AM
-
By Coume in forum General Support
Replies: 5
Last Post: 08-06-2003, 06:42 AM
-
By Terry@nz in forum General Support
Replies: 3
Last Post: 06-09-2003, 10:01 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

SK Hynix 32GB 2RX4 PC4-2666V DDR4 RDIMM Server Memory RAM, HMA84GR7AFR4N-VK
$169.95

Dell 16GB PC4-21300 (DDR4-2666) Memory (SNPPWR5TC16G)
$89.99

SMART(Micron)SafeStor 32GB(1X32GB) 1RX4 NN4-3200AA(DDR4) HPE Server Memory
$159.98

32GB Kit 4x8GB Wintec DDR4-2133 ECC RDIMM VLP Server RAM
$80.00

HYNIX 64GB (1X64GB) 2RX4 PC4-3200AA DDR4 SERVER MEMORY
$600.00

MTA36ASF4G72PZ-2G9E2 MICRON 32GB (1X32GB) 2RX4 PC4-2933Y MEMORY
$229.00

Lot 100 SK hynix 16GB 2Rx8 PC4-23400 DDR4-2933Y ECC Reg Server Memory RDIMM RAM
$9599.00

Kingston 32GB 64GB 128GB 256GB USB 3.0 Flash Drive Thumb Memory Stick Pen lot
$285.90

1/ 10/ 100pcs USB 2.0 2GB, 4GB ,8GB ,16GB ,32GB ,64GB 128GB USB Flash Drives Lot
$202.50

x4 Intel 128GB NMB1XXD128GPS Optane Memory 200 Series PMEM Module 3200 DDR4 RAM
$329.99