Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Emergency!!! Please Help

  1. #11
    Junior Member registered user
    Join Date
    Aug 2005
    Posts
    14

    The swap partition and the DMA query

    hi mark.
    on behalf of Adi me replying .
    the swap partition if of 1500 mb and my total hardisk space for the bootable partition i created for doing the remastering process is of 6.5 gb ..
    i hope u can help me out.
    in THe meanwhile can anyone tell me how to on the DMA ,,. so that i can try making New live cd in ten min or so rather than 2 hours time which its taking right now

  2. #12
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272

    Re: The swap partition and the DMA query

    Quote Originally Posted by mohit.jain.india
    can anyone tell me how to on the DMA ,,. so that i can try making New live cd in ten min or so rather than 2 hours time which its taking right now
    You can start it from konsole typing knoppix-dma and choosing devices. I usually choose all of them. From launch bar you can choose KNOPPIX - Utilities - Hardisk/CD/DVD DMA Acceleration. I hope that DMA mode could be enabled automatically in ide drives - in scsi drives you can't use it.

    But the time that how much DMA mode quickens remastering depends. I have an old 800 MHz Duron CPU but a new very fast ide hard drive with 8 MB cache. Remastering itself needs processing power but making isofs seems to depend more of hard disk speed.
    Anyhow, making comressed fs without DMA enabled taked an hour, with it half an hour. And making isofs really is fast in DMA mode, about 1 min. and without it 20 minutes!


    -tapsa-

  3. #13
    Member registered user
    Join Date
    Aug 2005
    Location
    India
    Posts
    30

    Re:

    I installed my hindi fonts by going to the control center -> Desktop ->Fonts. It shows me the fonts currently listed and there is an option of installing fonts. Since, I am doing a hard disk remastering..it was easy but the remastered version does not have those fonts though. I sucessfully did dpkg -reconfigure fontconfig.
    One another thing that happened with my remastered cd. If i use the cheat code knoppix 2, and then write startx in text mode..no problems occur..but booting knoppix without any cheat code..gives an IPC error...problem and the system crashes.
    Any ideas anyone..and thanks tr..u have been a great help. Any time you planning to come to india..i owe you a beer.

  4. #14
    Member registered user
    Join Date
    Aug 2005
    Location
    India
    Posts
    30

    Status

    Got my font installed on my remastered version.
    I have to boot in text mode and then write startx to make it run otherwise normal booting causes an IPC error.

    Some problems :
    Auto mount doesnt work anymore
    The default kDE style is different

    Any suggestions anyone??
    and thanks tr...u have been a great help.

  5. #15
    Junior Member registered user
    Join Date
    Aug 2005
    Posts
    14

    Error in IPC start up

    hi friends..
    thanks for the help u giving me in remastering .
    Me able to remaster Knoppix 3.8.2 and was able to run that in startx mode by using the cheat code 2 ,
    However me still getting the IPC error on normal booting
    And i just Got a Hint that it might be due to the Permissions setting or something.
    Me still unable to figure it out properly
    kindly help me out
    the error generated is
    • 'There was some error setting up inter-process communication for KDE. The message returned by the system was:' 'Could not read the network connection list. /home/entropy/DCOPserver_<hostname>_:0' 'Please check that the "dcopserver" program is running!'

  6. #16
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272

    Re: Error in IPC start up

    Quote Originally Posted by mohit.jain.india
    • 'There was some error setting up inter-process communication for KDE. The message returned by the system was:' 'Could not read the network connection list. /home/entropy/DCOPserver_<hostname>_:0' 'Please check that the "dcopserver" program is running!'
    Sorry, I didn't catch that IPC error had something to do with DCOPserver. That is a familiar message also to me but it has been so long ago that I have forgot what caused it.

    But some things to check in general:
    1. Is /etc/skel copied right to /home/knoppix?
    cp -Rp /etc/skel /home/knoppix
    2. Is owner and group of /home/knoppix knoppix?
    chmod -R knoppix:knoppix /home/knoppix
    3. Check that you really have /etc/X11/XF86Config-4 file existing.
    4. Check /etc/sysconfig, is desktop kde? Is progress file existing?

    Yes, this is really an autentication problem but sorry, I can't give an exact answer.


    Good luck!

    -tapsa-

  7. #17
    Member registered user
    Join Date
    Aug 2005
    Location
    India
    Posts
    30

    Re

    Hi, Tr
    Thaks for the help. Does checking out the read - write execute permission of /tmp also an issue.
    plz repy

  8. #18
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272

    Re: Re

    Quote Originally Posted by kooladi
    Thaks for the help. Does checking out the read - write execute permission of /tmp also an issue.
    Yes. At least from Knoppix 3.8.1 on chmod 1777 /tmp is taken care of in /etc/init.d/knoppix-autoconfig but it is not enough. This is what I have added to the end of knoppix-autoconfig (after last "fi"):
    Code:
    # Setting right permissions and owners to /tmp/.ICE-unix and /tmp/.X11-unix
    mkdir -p /tmp/.ICE-unix 2>/dev/null
    chown -R root:root /tmp/.ICE-unix 2>/dev/null
    chmod 1777 /tmp/.ICE-unix 2>/dev/null
    mkdir -p /tmp/.X11-unix 2>/dev/null
    chown -R root:root /tmp/.X11-unix 2>/dev/null
    chmod 1777 /tmp/.X11-unix 2>/dev/null
    I'm not a programmer and don't know if the syntax is perferctly right but it works for me

    Please look at your /home/knoppix/.xsession-errors so you see, why /tmp/.X11-unix and /tmp/.ICE-unix should also be taken care of.


    -tapsa-

  9. #19
    Member registered user
    Join Date
    Aug 2005
    Location
    India
    Posts
    30

    Re: Re

    Yes. At least from Knoppix 3.8.1 on chmod 1777 /tmp is taken care of in /etc/init.d/knoppix-autoconfig but it is not enough. This is what I have added to the end of knoppix-autoconfig (after last "fi"):
    Code:
    # Setting right permissions and owners to /tmp/.ICE-unix and /tmp/.X11-unix
    mkdir -p /tmp/.ICE-unix 2>/dev/null
    chown -R root:root /tmp/.ICE-unix 2>/dev/null
    chmod 1777 /tmp/.ICE-unix 2>/dev/null
    mkdir -p /tmp/.X11-unix 2>/dev/null
    chown -R root:root /tmp/.X11-unix 2>/dev/null
    chmod 1777 /tmp/.X11-unix 2>/dev/null
    I'm not a programmer and don't know if the syntax is perferctly right but it works for me

    Please look at your /home/knoppix/.xsession-errors so you see, why /tmp/.X11-unix and /tmp/.ICE-unix should also be taken care of.
    I am sorry for asking again but is the procedure same when doing remastering from hard disk. I am using nelsons script (who is not replying to any of my posts and PM's to him ) and it gives me no option for chroot.
    Pls help

  10. #20
    Member registered user
    Join Date
    Aug 2005
    Location
    India
    Posts
    30

    Finally !!!!

    Its official now...nelsons HD to LiveCD does not work..or work only with limited sucess. I have still not been albe to localize my version of Knoppix using his script and Underscore's tutorial is no good to me because I still face the 70% problem.
    So, I decided to cut away with the short cuts and go for the hard way of creating a live cd. Turns out, it just appears hard. I am proud to announce I have a LIVE CD up and running localized with my language in the very first attempt.
    Though, Underscore's HOW-TO was of great help (and god knows how much I have praised you reading that HOW-TO), I also took some help from Re-Mastering Wiki on this site.
    My sincere thanks to all those who helped me, listened to me whine and bitch about.
    I cant complete this without saying what a great help TR has been. I have been able to complete this largely because of his help.
    Thanks guys.

    [STATUS: Live Cd up and running. Looking for setting the local language as Default]

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Emergency ! KIndly help Fast.. A call to Tr TOo ..
    By mohit.jain.india in forum Customising & Remastering
    Replies: 2
    Last Post: 08-28-2005, 04:29 PM
  2. Emergency advice needed
    By djh-world in forum General Support
    Replies: 3
    Last Post: 02-15-2005, 07:08 PM
  3. Emergency - Grub Installation Problems!
    By gessi2000 in forum Hdd Install / Debian / Apt
    Replies: 8
    Last Post: 12-04-2004, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray picture

Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray

$39.99



Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A

$64.00



Western Digital 1TB 3.5

Western Digital 1TB 3.5" SATA III 7200RPM Desktop Hard Drive

$34.99



(ST8000NM0045) SEAGATE ENTERPRISE 8TB 7200RPM 4Kn SATA 6Gb/s 3.5

(ST8000NM0045) SEAGATE ENTERPRISE 8TB 7200RPM 4Kn SATA 6Gb/s 3.5" HARD DRIVE

$199.99



HGST 0F23072 Deskstar NAS 6TB SATA III 7200RPM 128MB 3.5in HDD picture

HGST 0F23072 Deskstar NAS 6TB SATA III 7200RPM 128MB 3.5in HDD

$84.99



Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE picture

Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE

$68.99



HGST HUA723030ALA640 3TB SATA 7200 RPM 3.5 in Enterprise HDD | 0F14044 (100%) picture

HGST HUA723030ALA640 3TB SATA 7200 RPM 3.5 in Enterprise HDD | 0F14044 (100%)

$45.00



Seagate Exos ST2000NX0253 HDD 2TB SATA 7.2K 2.5

Seagate Exos ST2000NX0253 HDD 2TB SATA 7.2K 2.5" 512b/s

$55.00



DELL 2TB Enterprise HDD (7200RPM, 3.5

DELL 2TB Enterprise HDD (7200RPM, 3.5", SATA III, 128MB Cache) HUS722T2TALA600

$49.95



Seagate ST12000NM0127 12TB 256MB 7200RPM 3.5

Seagate ST12000NM0127 12TB 256MB 7200RPM 3.5" SATA 6.0Gb/s Enterprise Hard Drive

$318.99