Results 1 to 10 of 10

Thread: Soundcard woes...

  1. #1
    Junior Member
    Join Date
    Apr 2003
    Posts
    6

    Soundcard woes...

    I have a Soundblaster Audigy card, and after some searching on the forums, I can see that it is not currently supported although it is correctly detected on boot. However, I could not see if it is possible to install drivers after booting knoppix and then saving the configuration so that each time knoppix is booted, the Audigy card is correctly supported. Is it possible?

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Do a:
    modprobe emu10k1
    See if that gets your audigy working.

  3. #3
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    Thank you - I'll try that as soon as I can.

  4. #4
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    I unfortunatly get error messages when I try that - when it tries to run emu10k1.o I get "init_module: no such device". Then insmod fails, and it suggests I look through the output from dmesg and that the failure is due to a IO or a IRQ error. I believe that the relavant bit of the output from dmesg is:

    Partition check:
    hda: hda1
    hdd:<3>ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    ldm_validate_partition_table(): Disk read failed.
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    unable to read partition table
    ....
    NTFS driver v1.1.22 [Flags: R/W MODULE]
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    ...
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 0
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 2
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 4
    ide-scsi: hdd: unsupported command in request queue (0)
    end_request: I/O error, dev 16:40 (hdd), sector 6
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0
    FAT: unable to read boot sector
    EFS: 1.0a - http://aeschi.ch.eu.org/efs/
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0
    EFS: cannot read volume header
    hdd : bad access: block=0, count=8
    end_request: I/O error, dev 16:40 (hdd), sector 0
    hdd : bad access: block=1, count=7
    end_request: I/O error, dev 16:40 (hdd), sector 1
    hdd : bad access: block=2, count=6
    end_request: I/O error, dev 16:40 (hdd), sector 2
    hdd : bad access: block=3, count=5
    end_request: I/O error, dev 16:40 (hdd), sector 3
    hdd : bad access: block=4, count=4
    end_request: I/O error, dev 16:40 (hdd), sector 4
    hdd : bad access: block=5, count=3
    end_request: I/O error, dev 16:40 (hdd), sector 5
    hdd : bad access: block=6, count=2
    end_request: I/O error, dev 16:40 (hdd), sector 6
    hdd : bad access: block=7, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 7
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0
    FAT: unable to read boot sector
    hdd : bad access: block=0, count=1
    end_request: I/O error, dev 16:40 (hdd), sector 0


    hda1 is a NTFS Windows XP Pro disk. I might be missing something obvious, but I don't see why this should make a difference - I have a permanent home set up on a ZIP disk and so there shouldn't be any reason at all to try and go to hda1, should there? I appreciate any help

    EDIT: Sorry, there was a bit more in the file that was relavant. Added. Also, the emu10k1 driver appears to be loaded already

    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
    spurious 8259A interrupt: IRQ7.
    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
    ...
    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003
    Creative EMU10K1 PCI Audio Driver, version 0.20, 15:49:50 Mar 26 2003


    If it's easier, I'll just upload the relavant files.

  5. #5
    Senior Member registered user
    Join Date
    Jan 2003
    Location
    Podunk, Idaho, USA
    Posts
    470
    All of those error messages are referring to hdd (I would assume the CD-Rom you are running from) I think that you have a bad CD.

    rock

  6. #6
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    I redownloaded Knoppix after a MD5 check on my old iso failed. It passed the MD5 check and I burnt it. However, I'm still getting the error messages when I try to modprobe emu10k1 and dmesg gives me the same errors.

  7. #7
    Junior Member registered user
    Join Date
    Apr 2003
    Location
    Rio Rancho, NM
    Posts
    16
    Quote Originally Posted by konsole
    modknoppix@ttyp1[knoppix]$ modprobe emu10k1
    /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o: create_module: Operation not permitted
    /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o: insmod /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o failed
    /lib/modules/2.4.20-xfs/kernel/drivers/sound/ac97_codec.o: insmod emu10k1 failed
    knoppix@ttyp1[knoppix]$
    You have to be logged in as root, no?
    As most of you can imagine, I'm on the CD Knoppix, and I was told that if you lock the terminal or try and log in as root, you can't because there's no pasword set or...something.

    Assistance?

  8. #8
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Quote Originally Posted by VxJasonxV
    You have to be logged in as root, no?
    As most of you can imagine, I'm on the CD Knoppix, and I was told that if you lock the terminal or try and log in as root, you can't because there's no pasword set or...something.

    Assistance?
    http://www.knoppix.net/docs/index.php/FaqUsing

  9. #9
    Junior Member
    Join Date
    Apr 2003
    Posts
    6
    I'm fairly sure that I've logged in as root, and yet I'm still getting those error messages

  10. #10
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Germany
    Posts
    297
    Quote Originally Posted by area
    I'm fairly sure that I've logged in as root, and yet I'm still getting those error messages
    Audigy works with alsa.

    See in changelog since when alsa is supported. Then start with: "knoppix alsa"

    cu

    Fabian

Similar Threads

  1. Woes Using CDs
    By A. Jorge Garcia in forum Hdd Install / Debian / Apt
    Replies: 10
    Last Post: 07-31-2005, 03:03 PM
  2. Apt-get woes
    By Shadda in forum Networking
    Replies: 1
    Last Post: 02-12-2005, 04:45 PM
  3. hd install woes
    By maul in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 07-13-2004, 01:56 PM
  4. ssh woes!!!
    By A. Jorge Garcia in forum General Support
    Replies: 4
    Last Post: 11-22-2003, 01:02 AM
  5. installation woes
    By sub_netter in forum Hardware & Booting
    Replies: 3
    Last Post: 04-02-2003, 08:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


IBM System X3850-X5 Server w/4x Intel  Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD picture

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD

$1299.99



IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM

$179.99



Unused IBM 09P0037 MAINBOARD For  RS/6000 7044-170 P-Series picture

Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series

$375.00



IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon  E5620 picture

IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620

$199.99



IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES picture

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES

$108.92



Compaq ProLiant 1500R 5/100 rack server, Series 3155, with IBM 2.1GB HD, VINTAGE picture

Compaq ProLiant 1500R 5/100 rack server, Series 3155, with IBM 2.1GB HD, VINTAGE

$295.00



IBM SERVER SLED WITH HDD SCSI 8.8GB ,P005043441, AS IS,UNTESTED picture

IBM SERVER SLED WITH HDD SCSI 8.8GB ,P005043441, AS IS,UNTESTED

$165.00



IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A picture

IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A

$1731.00



Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs picture

Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs

$49.99



IBM 02AN553  01LL325 IBM I/OADAPTER PCIe / PCN  Internal Server Systems Adapter picture

IBM 02AN553 01LL325 IBM I/OADAPTER PCIe / PCN Internal Server Systems Adapter

$199.99