I am trying to start x in the user space (knoppix) of the remasterd distro. I copied /etc/skel content to /home/knoppix :

code:
cp -Rp /etc/skel /home/knoppix
chown -R knoppix:knoppix /home/knoppix

and did copied /etc/X11/XF86Config-4 to the /etc/X11 folder of the remastered distro. Then I did the following:

code:
su - knoppix
export DISPLAY=localhost:0.0

Then I tried to start x

knoppix@4[~]$ startx
Using authority file /home/knoppix/.Xauthority
Writing authority file /home/knoppix/.Xauthority

X: user not authorized to run the X server, aborting.
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.
Couldnt get a file descriptor referring to the console

But when I do the same for the root, I can startx. How I can authourize knoppix to run X? Any idea?