Ok, I have Adriane Knoppix 6 installed to my second SCSI drive. I got the same error when appending the Adriane to the /boot/grub/menu.lst which was already working for me.

This is the menu.lst generated by 0wn..

default 0
timeout 30
color cyan/blue white/blue

title KNOPPIX
root (hd2,1)
kernel /boot/vmlinuz root=/dev/sdb2 lang=us keyboard=dvorak apm=power-off vga=791 nomce loglevel=0 quiet lang=us keyboard=dvorak rw

title Windows
rootnoverify (hd0,1)
chainloader +1
This is the /boot/grub/menu.lst generated by TeenPup Linux and with the 0wn generated entry for Adriane appended.

And highlighted.


# GRUB configuration file '/boot/grub/menu.lst'.
# generated by 'grubconfig'. Sun May 17 02:59:55 2009
#
# Start GRUB global section
#timeout 30
color light-gray/blue black/light-gray
# End GRUB global section
# Linux bootable partition config begins
title Linux (on /dev/sda1)
root (hd1,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal
# Linux bootable partition config ends
# Other bootable partition config begins
title Windows (on /dev/hda2)
map (hd0,0) (hd0,1)
map (hd0,1) (hd0,0)
rootnoverify (hd0,1)
makeactive
chainloader +1
# Other bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/hda3)
root (hd0,2)
kernel /boot/vmlinuz root=/dev/hda3 ro vga=normal
# Linux bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/sdb2)
root (hd2,1)
kernel /boot/vmlinuz root=/dev/sdb2 ro vga=normal

# Linux bootable partition config ends
title Install GRUB to floppy disk (on /dev/fd0)
pause Insert a formatted floppy disk and press enter.
root (hd0,2)
setup (fd0)
pause Press enter to continue.
title Install GRUB to Linux partition (on /dev/hda3)
root (hd0,2)
setup (hd0,2)
pause Press enter to continue.
title - For help press 'c', then type: 'help'
root (hd0)
title - For usage examples, type: 'cat /boot/grub/usage.txt'
root (hd0)
This is the boot message I get when booting either variant...

"[ 0.499891] dca service started, version 1.4
[ 0.558761] pci 000:01:00.0: BAR 6: Can't allocate mem resource [0xfe000000-0xfdffffff]
[ 0.572854] alg: cipher : Test 1 failed on encryption for aes-asm
[ 3.319802] IO APIC resources could not be allocated.
[ 4.044099] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
First partition is Knoppix 5.1

Second is M$ Windoze 2000

Third is Puppy Linux.

/sda1 is Freespire

All of them boot OK.