Results 1 to 2 of 2

Thread: Can't use internal network after dialup modem is used

  1. #1
    Junior Member
    Join Date
    Jun 2005
    Posts
    5

    Can't use internal network after dialup modem is used

    Just after reboot, can use internal network. However, once dialup modem
    is used internal network fails. And internal network continues to fail
    and _even_after_disconnecting_ the dialup modem. I use "kppp" to connect.

    In particular, during and after use of dialup modem, ping gives:

    ping: sendto: Operation not permitted

    ---------Details follow---------

    Am using crossover cable to connect two Knoppix PCs at 192.168.0.1 and
    192.168.0.2 and submask 255.255.255.0. Suppose 192.168.0.1 is PC1 and
    192.168.0.1 is PC2. PC1 is a Knoppix3.8 harddrive install (but many
    packages have been added since). PC2 is Knoppix4.0.2 live-DVD. Did
    network configuration on both PCs from KDE menu with:

    KNOPPIX > Network/Internet > Network card configuration

    Just after rebooting PC1 and starting up PC2, can do networking.
    As well as more advance operations, I can do this from PC1:
    $ ping -c 4 192.168.0.2
    PING 192.168.0.2 (192.168.0.2): 56 data bytes
    64 bytes from 192.168.0.2: icmp_seq=0 ttl=64 time=1.7 ms
    64 bytes from 192.168.0.2: icmp_seq=1 ttl=64 time=0.4 ms
    64 bytes from 192.168.0.2: icmp_seq=2 ttl=64 time=0.4 ms
    64 bytes from 192.168.0.2: icmp_seq=3 ttl=64 time=0.4 ms

    --- 192.168.0.2 ping statistics ---
    4 packets transmitted, 4 packets received, 0% packet loss
    round-trip min/avg/max = 0.4/0.7/1.7 ms

    However, I then use "kppp" with the dialup modem with PC1 (my
    harddrive install). After this, the internal network is broken. For
    instance, I can't ping PC2 from PC1 anymore (and vice versa):

    # ping -c 3 192.168.0.2
    PING 192.168.0.2 (192.168.0.2): 56 data bytes
    ping: sendto: Operation not permitted
    ping: wrote 192.168.0.2 64 chars, ret=-1
    ping: sendto: Operation not permitted
    ping: wrote 192.168.0.2 64 chars, ret=-1
    ping: sendto: Operation not permitted
    ping: wrote 192.168.0.2 64 chars, ret=-1

    --- 192.168.0.2 ping statistics ---
    3 packets transmitted, 0 packets received, 100% packet loss

    Also, with eth0 active, I can't access the dialup internet
    but access returns after I shut down eth0:

    $ ping -c 1 sf.net
    (...I wait 10 seconds but nothing happens...
    so I Ctrl-C but get no report...)

    $ su -c "ifdown eth0"
    Password:
    $ ping -c 1 sf.net
    PING sf.net (66.35.250.203): 56 data bytes
    64 bytes from 66.35.250.203: icmp_seq=0 ttl=52 time=311.6 ms

    --- sf.net ping statistics ---
    1 packets transmitted, 1 packets received, 0% packet loss
    round-trip min/avg/max = 311.6/311.6/311.6 ms

    Here is extra info from PC1 (notice no ppp0 entry in "interfaces):

    $ cat /etc/network/interfaces
    # /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

    # The loopback interface
    # automatically added when upgrading
    auto lo eth0
    iface lo inet loopback

    iface eth0 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.10
    $ su -c "ifup eth0"
    Password:
    $ ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:01:29:FA:C6:15
    inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::201:29ff:fefa:c615/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:767 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1314 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:77371 (75.5 KiB) TX bytes:133720 (130.5 KiB)
    Interrupt:23 Base address:0xa000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:383898 errors:0 dropped:0 overruns:0 frame:0
    TX packets:383898 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:78166138 (74.5 MiB) TX bytes:78166138 (74.5 MiB)

    ppp0 Link encap:Point-to-Point Protocol
    inet addr:66.203.170.142 P-t-P:10.1.1.152 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:6510 errors:21 dropped:0 overruns:0 frame:0
    TX packets:5793 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:8100282 (7.7 MiB) TX bytes:342900 (334.8 KiB)

    sit0 Link encap:IPv6-in-IPv4
    NOARP MTU:1480 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

  2. #2
    Junior Member
    Join Date
    Jun 2005
    Posts
    5
    FIXED -- needed to run script with iptables and maybe other stuff.

    Anyway, for future reference, the script here solved my problem:

    http://www.aboutdebian.com/network.htm

    Followup question: What are some good GUI level tool(s) that would set up this script
    for a Linux newbie type?

Similar Threads

  1. Dialup BestData serial modem
    By bhawns in forum Networking
    Replies: 0
    Last Post: 03-19-2007, 11:48 PM
  2. D-LINK Dialup modem :: No Dial Tone
    By AJones in forum Networking
    Replies: 1
    Last Post: 12-31-2005, 10:12 PM
  3. How To Install Modem Aztech Internal Modem Msp3880
    By Mic Q in forum General Support
    Replies: 0
    Last Post: 11-17-2004, 02:17 PM
  4. how to install dialup modem??
    By tsitras in forum Networking
    Replies: 1
    Last Post: 06-19-2004, 11:52 PM
  5. knoppix 3.3 won't open modem or dialup
    By daytek in forum Networking
    Replies: 0
    Last Post: 04-13-2004, 04:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


IBM System X3850-X5 Server w/4x Intel  Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD picture

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD

$1299.99



IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM

$179.99



Unused IBM 09P0037 MAINBOARD For  RS/6000 7044-170 P-Series picture

Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series

$375.00



Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs picture

Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs

$49.99



IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5

IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5" Server Hard Drive

$200.00



IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES picture

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES

$110.30



IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU picture

IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU

$999.99



IBM System x3550 M3 1U Server Intel Xeon E5630 4GB DDR3 No HDD picture

IBM System x3550 M3 1U Server Intel Xeon E5630 4GB DDR3 No HDD

$279.99



IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon  E5620 picture

IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620

$199.99



IBM Server Rackmount Sliding Rail Kit ( Part Numbers: 00D9375 / 00D9374 ) picture

IBM Server Rackmount Sliding Rail Kit ( Part Numbers: 00D9375 / 00D9374 )

$24.99