-
Can't use internal network after dialup modem is used
Just after reboot, can use internal network. However, once dialup modem
is used internal network fails. And internal network continues to fail
and _even_after_disconnecting_ the dialup modem. I use "kppp" to connect.
In particular, during and after use of dialup modem, ping gives:
ping: sendto: Operation not permitted
---------Details follow---------
Am using crossover cable to connect two Knoppix PCs at 192.168.0.1 and
192.168.0.2 and submask 255.255.255.0. Suppose 192.168.0.1 is PC1 and
192.168.0.1 is PC2. PC1 is a Knoppix3.8 harddrive install (but many
packages have been added since). PC2 is Knoppix4.0.2 live-DVD. Did
network configuration on both PCs from KDE menu with:
KNOPPIX > Network/Internet > Network card configuration
Just after rebooting PC1 and starting up PC2, can do networking.
As well as more advance operations, I can do this from PC1:
$ ping -c 4 192.168.0.2
PING 192.168.0.2 (192.168.0.2): 56 data bytes
64 bytes from 192.168.0.2: icmp_seq=0 ttl=64 time=1.7 ms
64 bytes from 192.168.0.2: icmp_seq=1 ttl=64 time=0.4 ms
64 bytes from 192.168.0.2: icmp_seq=2 ttl=64 time=0.4 ms
64 bytes from 192.168.0.2: icmp_seq=3 ttl=64 time=0.4 ms
--- 192.168.0.2 ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 0.4/0.7/1.7 ms
However, I then use "kppp" with the dialup modem with PC1 (my
harddrive install). After this, the internal network is broken. For
instance, I can't ping PC2 from PC1 anymore (and vice versa):
# ping -c 3 192.168.0.2
PING 192.168.0.2 (192.168.0.2): 56 data bytes
ping: sendto: Operation not permitted
ping: wrote 192.168.0.2 64 chars, ret=-1
ping: sendto: Operation not permitted
ping: wrote 192.168.0.2 64 chars, ret=-1
ping: sendto: Operation not permitted
ping: wrote 192.168.0.2 64 chars, ret=-1
--- 192.168.0.2 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
Also, with eth0 active, I can't access the dialup internet
but access returns after I shut down eth0:
$ ping -c 1 sf.net
(...I wait 10 seconds but nothing happens...
so I Ctrl-C but get no report...)
$ su -c "ifdown eth0"
Password:
$ ping -c 1 sf.net
PING sf.net (66.35.250.203): 56 data bytes
64 bytes from 66.35.250.203: icmp_seq=0 ttl=52 time=311.6 ms
--- sf.net ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 311.6/311.6/311.6 ms
Here is extra info from PC1 (notice no ppp0 entry in "interfaces):
$ cat /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
# The loopback interface
# automatically added when upgrading
auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.10
$ su -c "ifup eth0"
Password:
$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:01:29:FA:C6:15
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::201:29ff:fefa:c615/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:767 errors:0 dropped:0 overruns:0 frame:0
TX packets:1314 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:77371 (75.5 KiB) TX bytes:133720 (130.5 KiB)
Interrupt:23 Base address:0xa000
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:383898 errors:0 dropped:0 overruns:0 frame:0
TX packets:383898 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:78166138 (74.5 MiB) TX bytes:78166138 (74.5 MiB)
ppp0 Link encap:Point-to-Point Protocol
inet addr:66.203.170.142 P-t-P:10.1.1.152 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:6510 errors:21 dropped:0 overruns:0 frame:0
TX packets:5793 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:8100282 (7.7 MiB) TX bytes:342900 (334.8 KiB)
sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
-
FIXED -- needed to run script with iptables and maybe other stuff.
Anyway, for future reference, the script here solved my problem:
http://www.aboutdebian.com/network.htm
Followup question: What are some good GUI level tool(s) that would set up this script
for a Linux newbie type?
Similar Threads
-
By bhawns in forum Networking
Replies: 0
Last Post: 03-19-2007, 11:48 PM
-
By AJones in forum Networking
Replies: 1
Last Post: 12-31-2005, 10:12 PM
-
By Mic Q in forum General Support
Replies: 0
Last Post: 11-17-2004, 02:17 PM
-
By tsitras in forum Networking
Replies: 1
Last Post: 06-19-2004, 11:52 PM
-
By daytek in forum Networking
Replies: 0
Last Post: 04-13-2004, 04:38 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray
$39.99

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A
$64.00

Toshiba DT01ACA100 1 TB 3.5" SATA III 3.5 in Desktop Hard Drive
$24.99

Seagate Barracuda ST1000DM003 1 TB SATA III 3.5 in Desktop Hard Drive
$23.99

Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE
$68.99

Seagate ST3000NM0005 HDD 3TB SATA 6Gb/s 7.2K 3.5" 512 b/s
$59.00

Toshiba MG03ACA400 4TB 7200 RPM SATA 6.0Gb/s 3.5" Enterprise HDD (V6313)
$61.56

Western Digital Gold 2TB WD2005FBYZ-01YCBB2 3.5" 7200 RPM SATA Hard Drive
$59.99

New Western Digital WD40EFPX 68C6CN0 4TB 3.5" SATA III Internal NAS Red Plus HDD
$137.59

Tested WD Ultrastar DC HC520 12TB 7.2K RPM SATA 6Gb/s 3.5" HDD HUH721212ALN600
$239.99