Just found the problem.
Using the failsafe option boots Knoppix with both Serial ATA drives enabled.
Hello,
I can't boot Knoppix 4.0.2 or 4.0.0 (both DVD-Version). The DVDs should be alright, because they can boot on other systems. Knoppix 3.8, Kanotix and many other Linux-Live CDs or DVDs can boot without any problems.
Does anybody know, if there is a trick to boot or is there an error with the boot loader of Knoppix 4.0.x. The systems hangs when trying to identify the Serial ATA harddrives. When I disconnect the Serial ATA drives the boot-process suceeds and I can log in into Knoppix.
Any hints?
Just found the problem.
Using the failsafe option boots Knoppix with both Serial ATA drives enabled.
i found this problem on my celeron1000. do not know why but version 3.6 and higher, also the STD version do not want to boot here.
![]()
Have you tried it with the failsafe option? With that option enabled it worked for me.
Looks like a bug in the auto detection of Knoppix 4.0.x. I have tried many other distributions and no other showed this problem.
yes with failsafe it boots ok, but i think it is not just the 4.0 version , in my case it was also with 3.6 , 3.7 and 3.9

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD
$1299.99
IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM
$179.99
Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series
$375.00
IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620
$199.99
IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES
$108.92
IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A
$1731.00
IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5" Server Hard Drive
$200.00
IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU
$999.99
IBM Server Rackmount Sliding Rail Kit ( Part Numbers: 00D9375 / 00D9374 )
$24.99
Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs
$49.99