Results 1 to 5 of 5

Thread: Help - Remaster failing to boot

  1. #1
    Junior Member
    Join Date
    Apr 2003
    Posts
    3

    Help - Remaster failing to boot

    Hi,

    First off I want to say I love Knoppix. I'm a NetAdmin and it has saved me a few times. I have incorporated it into my disaster recovery plan.

    I want to remaster it to be able to add and remove some programs specific to my needs.

    I have been successful in pairing down Knoppix but I haven't been able to get my new iso to boot.

    I am using an existing Linux (RedHat 7.3) system that has EXT3 partitions.

    Here is the process I used to remaster. Maybe someone can tell me what I did wrong:

    - I started using the KnoppixRemasteringHowTo from www.knoppix.net.
    - I am able to get to point of chroot to do my customizations
    - The customizing:
    run apt-get update
    run apt-get install aptitude
    run aptitude to remove programs - I didn't add any at this point
    once my selections are made I use the download option to do it's thing
    I notice that sysinit seems to get upgraded as does LILO
    The LILO part of the upgrade asks if I want to make new configs - I say no
    - after aptitude does it's thing I continue with the RemasterFAQ
    - I am able to make the iso with no problem

    The problem now is it won't boot.

    I get the message that it wants the root password to enter the maintenance mode. This happens during the AutoMount part of the boot up. (I can post the exact message - it's quite long) It seems like it fails trying to fsck an EXT2 partition.

    Can anyone point me in the right direction? Once I get my "NetAdmin" version of Knoppix working I will gladly upload it for everyone to get.

    Thanks in advance for any help.
    Sheldon

  2. #2
    Member registered user
    Join Date
    Mar 2003
    Posts
    35
    when you copy the files from the knoppix compressed FS, make sure you are root, and make sure you use the cp flag -p

  3. #3
    Junior Member
    Join Date
    Apr 2003
    Posts
    3
    Hi SillyFly,

    Thanks for the info. I have tried that...I did make sure I was root and I used the command:

    cp -Rp /KNOPPIX/* /mnt/hda4/knx/source/KNOPPIX

    /mnt/hda4 was my remastering partition. I also used the -R option to make sure and directories and subdirectories were also copied.

    Is there anything else that I may have missed?

    Thanks
    Sheldon

  4. #4
    Junior Member
    Join Date
    Apr 2003
    Posts
    3
    Sorry, I should have mentioned that it did not work in my last post. I get the same results.

  5. #5
    Member registered user
    Join Date
    Mar 2003
    Posts
    35
    hmm....
    maybe try manualy fsck'ing that partiotion?
    anyway, posting the message you get may give more clues as to what went wrong....

Similar Threads

  1. MY TALE OF TRYING TO INSTALL KNOPPIX AND FAILING MISERABLY
    By Qizz in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 12-16-2004, 02:58 AM
  2. Trying to use the captive script... and failing
    By denisvh in forum General Support
    Replies: 0
    Last Post: 05-20-2004, 05:51 PM
  3. failing boot floppy creation
    By nishtya in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 03-29-2004, 03:45 AM
  4. Failing to update packages post hdd install
    By todsr1 in forum General Support
    Replies: 8
    Last Post: 11-02-2003, 10:36 AM
  5. XFS install failing ..
    By tfitzgex in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 04-08-2003, 05:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W

$409.99



Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram  2x 550W PSU No HDD picture

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD

$275.00



Microsoft Windows Server 2025 Standard 64bit 32 Core-50 CALs DVD With Key Sealed picture

Microsoft Windows Server 2025 Standard 64bit 32 Core-50 CALs DVD With Key Sealed

$95.99



Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed picture

Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed

$41.19



Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p picture

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p

$499.88



Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO picture

Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO

$308.00



Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD picture

Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD

$381.93



Dell PowerEdge R240 Intel Xeon E-2144G 3.6GHz 16GB DDR4 ECC NO HDD 250W  Unused picture

Dell PowerEdge R240 Intel Xeon E-2144G 3.6GHz 16GB DDR4 ECC NO HDD 250W Unused

$189.00



Dell Intel X710-DA2 5N7Y5 Dual-Port 10GbE SFP+ PCIe 3.0 x8 Network Adapter picture

Dell Intel X710-DA2 5N7Y5 Dual-Port 10GbE SFP+ PCIe 3.0 x8 Network Adapter

$27.50



DELL POWEREDGE R340 Server | Xeon E-2126G 64GB RAM PERC H330 (Onboard) picture

DELL POWEREDGE R340 Server | Xeon E-2126G 64GB RAM PERC H330 (Onboard)

$399.95