Results 1 to 8 of 8

Thread: apache2 not working no index.html

  1. #1
    Member registered user
    Join Date
    Apr 2005
    Posts
    93

    apache2 not working no index.html

    Spoke too soon. I thought my disk was working and didn't try index page with apache2 as my php5 and tomcat5 default pages came up I assumed index.html would. I have changed apache2.conf, /etc/default/apache2 to 0 and commented out redirect in /etc/apache2/sites-available/default. Suggestions found on the web. I've put the contents of these below to see if anything appears to be wrong
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
    # in /apache2-default/, but still have / go to the right place
    #RedirectMatch ^/$ /apache2-default/
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined
    ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    </VirtualHost>

  2. #2
    Member registered user
    Join Date
    Apr 2005
    Posts
    93

    apache2 not working

    When this didn't work I added the server name like this:


    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, instead of the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to
    # prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
    #
    #Listen 12.34.56.78:80
    Listen 80

    #ServerAdmin: Your address, where problems with the server should be
    # e-mailed. This address appears on some server-generated pages, such
    # as error documents. e.g. [email protected]
    #
    ServerAdmin webmaster@localhost

    I got the following error report:

    /etc/init.d/apache2 force-reload
    Forcing reload of web server: Apache2 ... no pidfile found! not running?apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    (9Address already in use: make_sock: could not bind to address [::]:80
    no listening sockets available, shutting down
    Unable to open logs

    does anyone know what the problem is

  3. #3
    Member registered user
    Join Date
    Apr 2005
    Posts
    93

    apache2 index.html

    and the following from my /etc/hosts file

    127.0.0.1 Knoppix localhost

    # The following lines are desirable for IPv6 capable hosts
    # (added automatically by netbase upgrade)

    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

  4. #4
    Junior Member
    Join Date
    May 2006
    Location
    nw england
    Posts
    1

    did you solve this?

    I am experiencing the same problem and have tried virtually exactly the same steps.

    further problems I have discovered is that a site created in a subfolder is accessible but all image links and css include statements are dead.

    have you got any closer to a solution or can anyone suggest one.

  5. #5
    Member registered user
    Join Date
    Apr 2005
    Posts
    93

    apache2

    sorry when i finished my project i didn't look at it again. in the end i just carried on with an updated version of apache 1.3. I haven't looked at knoppix for a while so i don't know what version is current, but the KNOPPIX 4.0 version had knoppix 2.0 preinstalled I think. Good Luck and if you do get an answer please post it for future reference

  6. #6
    Junior Member
    Join Date
    Sep 2006
    Posts
    1
    I found out that when I create a simple html file which just contain somthing like
    <html>
    <body>
    blar blar blar.....
    </body>
    </html>

    and if the file size is less than or equal 255 bytes. The page will display correctly. If the file size is greather than 255 then it will have the problem. Don't see the problem when using within the chroot. May be the problem is from UNIONFS+Apache2???

  7. #7
    Junior Member registered user
    Join Date
    Apr 2003
    Posts
    13

    It worked for me

    I solved it by adding this line to httpd.conf:

    EnableSendfile Off

    Found here:
    http://www.apachefriends.org/f/viewt...?p=86298#86298
    (in german)

    Best regards

  8. #8

    knoppix 5.0.1 & apache2

    knoppix 5.0.1
    apache2

    you need to add

    EnableSendfile Off

    to httpd.conf

Similar Threads

  1. Shows index.html only after end current session
    By leonidas in forum Customising & Remastering
    Replies: 0
    Last Post: 04-28-2006, 11:56 AM
  2. Run script with Index.html @ boot
    By eshindi in forum Customising & Remastering
    Replies: 1
    Last Post: 03-31-2006, 05:51 AM
  3. Index.html in /ramdisk/var/www and chainging permissions
    By JHM_MKE in forum General Support
    Replies: 3
    Last Post: 08-30-2004, 03:48 PM
  4. file:/cdrom/index.html
    By KnoppiXRuleZ in forum General Support
    Replies: 0
    Last Post: 03-14-2004, 11:07 PM
  5. file:/cdrom/index.html
    By KnoppiXRuleZ in forum General Support
    Replies: 0
    Last Post: 03-14-2004, 11:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Apple Computer cards VTG 670-8020-B  607-0103-C  607-0291-C AST -Orange Micro ++ picture

Apple Computer cards VTG 670-8020-B 607-0103-C 607-0291-C AST -Orange Micro ++

$169.00



Vintage Apple iMac G4 15

Vintage Apple iMac G4 15" Lamp 700MHz 512MB Mac OS X 10.4.6 W/ Pro Speakers

$300.00



Vintage Apple II Avant-Garde Creations  Super Shape Draw And Animate 1981 picture

Vintage Apple II Avant-Garde Creations Super Shape Draw And Animate 1981

$295.00



Rare Vintage Macintosh Apple Wooden Disk Storage Box Dovetailed picture

Rare Vintage Macintosh Apple Wooden Disk Storage Box Dovetailed

$69.95



LARGE LOT Vintage Apple Macintosh Mouse Cables Accessories SCSI etc - UNTESTED picture

LARGE LOT Vintage Apple Macintosh Mouse Cables Accessories SCSI etc - UNTESTED

$80.00



Vintage Apple iBook G3 12.1” 500MHz 2001 Restored, SSD Upgraded Mac OS 9.2/OS X picture

Vintage Apple iBook G3 12.1” 500MHz 2001 Restored, SSD Upgraded Mac OS 9.2/OS X

$180.00



Lot of 3 VIntage  Apple Computer Rainbow Logo Sticker Decal Macintosh 1980s NOS picture

Lot of 3 VIntage Apple Computer Rainbow Logo Sticker Decal Macintosh 1980s NOS

$7.00



Vintage Apple PowerBook 15” G4 “Aluminum” (1.25GHz/2gb/150gb/Tiger) 2 picture

Vintage Apple PowerBook 15” G4 “Aluminum” (1.25GHz/2gb/150gb/Tiger) 2

$109.99



Vintage Apple Monitor IIc 9

Vintage Apple Monitor IIc 9" Green Monochrome 06/1985 A2M4090 October 1984 Stand

$275.00



Vintage Apple Multiple Scan 15av Display Monitor M4681 picture

Vintage Apple Multiple Scan 15av Display Monitor M4681

$299.99