-
Junior Member
registered user
DCOP communications error
Hi,
I'm using knoppix 4.02 on a laptop. When I open KUser, it asks for the root password and I
enter it. Then it gives an error message:
********************************************
DCOP communications error (KUser)
There was an error setting up inter-process communications for kde. The
message returned by the system was:
Could not read network connection list.
/root/.DCOPserver_Knoppix__0
Please check that the "dcopserver" program is running!
************************************************** **
Any ideas on how to avoid/fix this?
neilsanner
-
Senior Member
registered user
neilsanner,
I used to get that a lot, this, and another message, usually when I tried to fire up a Konqueror "root" screen as well... With the Konsole, I'd get what message you state, for a Konq., I'd get some message about "not being able to connect to Display 0:0", or something like that...
In either case, the end effect was, the screen would never start the process, and it would sit for a while, and then die off.
I never resolved how to fix the problem, I never really minded, that much, about it... Most of the cases, (my "simple" attempt to fix the issue, was: ) -=- to reboot... After rebooting, the problem would be gone, until, the next time the error cropped up again.
I am not sure what the issue was, what caused it, nor the "real" resolve. The problem happened to me back with Knoppix v3.1, 3.2, 3.3, and v3.4 -=- I then moved over to Kanotix, so, I cant say anything about the "newer" versions of Knoppix, and this occurance. The biggest problem I seemed to have, was, trying to figure out WHY it happened. I think the process "died", but, why? After rebooting, the process would get re-started, but, why did it die?
You might be able to re-start the process again, if, it has a start function in /etc/init.d/"name" ?
In other words, if you can find a script, or program, in /etc/init.d/dcopserver - you might be able to restart it by doing this in a root Konsole:
/etc/init.d/dcopserver start
again, if the problem on why it got shutdown in the first place, is not resolved, the start would probably fail, or shortly after it starts, it would die off, though...
Best I can come up with here, hope it helps,
Ms. Cuddles
-
Junior Member
registered user
Cuddles,
Thank you very much for your thoughts.
If Kanotix would work better I'd be glad to use it. The problem is, it doesn't recognize my Wi-Fi network card out of the box...
I hope this problem will be fixed in next releases of Knoppix.
Cheers!
neilsanner
Similar Threads
-
By metalradio9 in forum Hdd Install / Debian / Apt
Replies: 2
Last Post: 03-25-2007, 02:01 AM
-
By sag in forum General Support
Replies: 1
Last Post: 05-15-2006, 08:20 PM
-
By TEHark1 in forum General Support
Replies: 1
Last Post: 03-23-2006, 08:40 AM
-
By mlopes in forum Customising & Remastering
Replies: 1
Last Post: 09-12-2005, 04:25 PM
-
By mohit.jain.india in forum Customising & Remastering
Replies: 0
Last Post: 08-30-2005, 05:05 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray
$39.99

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A
$64.00

DELL 2TB Enterprise HDD (7200RPM, 3.5", SATA III, 128MB Cache) HUS722T2TALA600
$49.95

Seagate ST500DM009 BarraCuda 500 GB 3.5" SATA III Desktop Hard Drive
$14.99

Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE
$68.99

HGST HUS724040ALA640 HDD 4TB SATA 6Gb/s 7.5K 3.5" 0F19459 512 b/s
$78.00

HGST HUA723030ALA640 3TB SATA 7200 RPM 3.5 in Enterprise HDD | 0F14044 (100%)
$45.00

HGST Ultrastar 7K4000 3TB 7200RPM SATA III 3.5" Hard Drive HDD HUS724030ALA640
$39.99

(ST8000NM0045) SEAGATE ENTERPRISE 8TB 7200RPM 4Kn SATA 6Gb/s 3.5" HARD DRIVE
$199.99

Seagate ST12000NM0127 12TB 256MB 7200RPM 3.5" SATA 6.0Gb/s Enterprise Hard Drive
$318.99