-
Boot problem after install to HD
Dear all,
I just install Knoppix new version by follow the instruc... My hard disk already run Redhat 9 and windows XP. When install the Knoppix I also delete Redhat by raplate partition. I just wonder that in list of partitions for install Knoppix I only see one partition that is "/" of Redhat without any partition for boot or swap. But anyway I follow up to install Knoppix . Affter finish I restart and receive error mesenger like this
"Kernel panic - not syncing : VFS: unable to mount root fs on unknow-block(36)
So please help me to fix it.
Thanks
-
Senior Member
registered user
babyyou,
That error is typically generated when the kernel can't find a table entry for the root partition.
You may have a corrupted partition table. I find your post somewhat hard to understand so i can't really offer much more on this except ...
Could you provide a more ordered description of the situation. Just so folks don't have to guess.
You say, or rather, it appears as your saying that your partitioning for the knoppix install involved wiping your RH install.
I assume you either installed in the same location or resized the area.
I would also guess that what ever Linux boot loader your using was likely installed to the mbr. And i would expect that it was installed with your knoppix. If the loader was from your RH install, and as you seem to have "removed" RH, you would likely have a Loader error rather than a kernel error. True for Lilo at least. Though .... if it is Grub, and you installed to the same partition as existed for RH ... then grub would likely still find its secondary files.
But here i am making guesses.
Please clarify ....
Where are you getting thethe following from ....
>>
in list of partitions for install Knoppix I only see one partition that is "/" of Redhat without any partition for boot or swap.
>>
/etc/fstab ???
How ???
Are you using the LiveCD and mounting the install ???
Not possible if the table entry is missing !
Can you boot into your XP ???
If not, ie; can't boot into anything ...
Boot the LiveCD and post the output from,
]# cfdisk -Pt /dev/hda
please.
hda = your first drive, assuming ide. Change to whatever it might be.
Without the info there isn't much point in anyone responding to your question really. No offence if that sounds harsh either. I'm just trying to be helpful on those points 
jm
Humpty Dumpty Was Pushed !
Similar Threads
-
By destro in forum MS Windows & New to Linux
Replies: 4
Last Post: 04-01-2007, 11:08 PM
-
By ILoveKagome in forum Hdd Install / Debian / Apt
Replies: 1
Last Post: 01-07-2007, 11:58 PM
-
By hazelkid in forum Hdd Install / Debian / Apt
Replies: 2
Last Post: 09-02-2006, 04:57 PM
-
By fadeh in forum Hdd Install / Debian / Apt
Replies: 1
Last Post: 12-30-2005, 04:51 PM
-
By bbouton in forum Hdd Install / Debian / Apt
Replies: 3
Last Post: 03-10-2004, 03:04 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

HP PROLIANT TPS-W003 MICRO- SERVER TOWER Gen 8, 16G RAM
$195.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99

Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On
$450.00

Supermicro 505-2 Server
$280.00

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS
$199.00

Supermicro 1027GR-TSF 1U Rackmount Server 2x Xeon 2.3GHz 128GB DDR3
$219.99

Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99

HP Proliant MicroServer Gen8, 4.5TB, (4) HDD, EXCELLENT COND.
$625.00

Supermicro CSE-216 No CPU No Ram No HDD Tested & Reset
$149.99

Nasuni NF-50 Supermicro Server, Atom CPU C2558, @ 2.40GHz, 8GB RAM-No HDD/OS/AC
$187.50