To me work this one:
xinit -- :1
System: Knoppix 5 DVD
Knoppix is normal running in init 5
If I try to start a second X on console 2 with startx -- :1, the graphic screen appears, the mouse-pointer is active for 2 seconds, after that I returned zu text-console with the following messages:
If I try to start Xnest :1, I getCode:xauth: creating new authority file //.serverauth.3854 xauth: creating new authority file //.Xauthority xauth: creating new authority file //.Xauthority X: warning; process set to priority -11 instead of requested priority -10 X Window System Version 7.0.0 Release Date: 21 December 2005 X Protocol Version 11, Revision 0, Release 7.0 Build Operating System:Linux 2.6.12-1-686 i686 Current Operating System: Linux Knoppix 2.6.17 #4 SMP PREEMPT Wed May 10 13:53:45 CEST 2006 i686 Build Date: 16 March 2006 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. Module Loader present Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.1.log", Time: Thu Jun 29 14:50:46 2006 (==) Using config file: "/etc/X11/xorg.conf" The XKEYBOARD keymap compiler (xkbcomp) reports: > Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols > Ignoring extra symbols Errors from xkbcomp are not fatal to the X server Could not init font path element /usr/share/fonts/X11/TTF/, removing from list! Could not init font path element /usr/share/fonts/X11/OTF, removing from list! Could not init font path element /usr/share/fonts/X11/CID/, removing from list! AUDIT: Thu Jun 29 14:50:51 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:53 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 waiting for X server to shut down FreeFontPath: FPE "/usr/share/fonts/X11/misc:unscaled" refcount is 2, should be 1; fixing.
What is the problem?Code:Fatal Server Error: Unable to open display "".
Ciao
Frank
To me work this one:
xinit -- :1
Yes, but two problems:Originally Posted by maxIT
1.) why is xinit -- :1 running, but startx -- :1 not?
2.) if starting a second X with xinit -- :1, I've got problems on display :0 like can't open konqerer
Now I will explain my procedure with knoppix 3.8.2:
All X envinronments works properly to me.1 - load cd. And kde is launched by default, in console 5.
2 - type 'ctrl-alt-f1', to log-in in the first console (text-mode)
3 - type 'xinit -- :1' and an x-session will be opened in console 6.
4 - type 'ctrl-alt-f2', to login int the 2nd text mode console.
5 - type 'startx -- :2' and an x-session with kde will be open in console 7.
Now I can switch back and fotrh between console 5 (kde default), console 6 (strictly X without any kind of windows managers enabled) and console 7 (new kde launched in step 5) using 'ctrl-alt-f5', 'ctrl-alt-f6' and 'ctrl-alt-f7' combin-keys.
Yes, it seems to be a problem of Knoppix 5.Originally Posted by maxIT
If I start my old Knoppix 3.9 on the same hardware, all works too!
Ciao
Frank
Could it be the use of Xorg version 7.0 in Knoppix 5.0.1, rather than Xfree86 as in prior versions?

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p
$499.88
Dell PowerEdge R740xd Dual Intel Silver 4116 @2.1GHz 32GB HBA330 24Bay Server
$525.00
Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD
$275.00
Dell Intel X710-DA2 5N7Y5 Dual-Port 10GbE SFP+ PCIe 3.0 x8 Network Adapter
$27.50
Dell PowerEdge R730 8 Bay Server 64Gb 1x80Gb SSD 3x900Gb SAS 2x12c v4CPU Proxmox
$620.00
Dell PowerEdge R640 1U 8SFF Server Barebones 2x Gold 5120 64GB H330 2x 750w
$238.88
Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb
$374.99
Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W
$484.99
DELL POWEREDGE R340 Server | Xeon E-2126G 64GB RAM PERC H330 (Onboard)
$399.95
Dell Poweredge C4130 2x LGA2011-3 1U 4x GPU Rackmount Server CTO (NO CPU/NO RAM)
$299.95