To me work this one:
xinit -- :1
System: Knoppix 5 DVD
Knoppix is normal running in init 5
If I try to start a second X on console 2 with startx -- :1, the graphic screen appears, the mouse-pointer is active for 2 seconds, after that I returned zu text-console with the following messages:
If I try to start Xnest :1, I getCode:xauth: creating new authority file //.serverauth.3854 xauth: creating new authority file //.Xauthority xauth: creating new authority file //.Xauthority X: warning; process set to priority -11 instead of requested priority -10 X Window System Version 7.0.0 Release Date: 21 December 2005 X Protocol Version 11, Revision 0, Release 7.0 Build Operating System:Linux 2.6.12-1-686 i686 Current Operating System: Linux Knoppix 2.6.17 #4 SMP PREEMPT Wed May 10 13:53:45 CEST 2006 i686 Build Date: 16 March 2006 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. Module Loader present Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.1.log", Time: Thu Jun 29 14:50:46 2006 (==) Using config file: "/etc/X11/xorg.conf" The XKEYBOARD keymap compiler (xkbcomp) reports: > Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols > Ignoring extra symbols Errors from xkbcomp are not fatal to the X server Could not init font path element /usr/share/fonts/X11/TTF/, removing from list! Could not init font path element /usr/share/fonts/X11/OTF, removing from list! Could not init font path element /usr/share/fonts/X11/CID/, removing from list! AUDIT: Thu Jun 29 14:50:51 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:53 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 AUDIT: Thu Jun 29 14:50:54 2006: 3872 X: client 2 rejected from local host Auth name: MIT-MAGIC-COOKIE-1 ID: -1 waiting for X server to shut down FreeFontPath: FPE "/usr/share/fonts/X11/misc:unscaled" refcount is 2, should be 1; fixing.
What is the problem?Code:Fatal Server Error: Unable to open display "".
Ciao
Frank
To me work this one:
xinit -- :1
Yes, but two problems:Originally Posted by maxIT
1.) why is xinit -- :1 running, but startx -- :1 not?
2.) if starting a second X with xinit -- :1, I've got problems on display :0 like can't open konqerer
Now I will explain my procedure with knoppix 3.8.2:
All X envinronments works properly to me.1 - load cd. And kde is launched by default, in console 5.
2 - type 'ctrl-alt-f1', to log-in in the first console (text-mode)
3 - type 'xinit -- :1' and an x-session will be opened in console 6.
4 - type 'ctrl-alt-f2', to login int the 2nd text mode console.
5 - type 'startx -- :2' and an x-session with kde will be open in console 7.
Now I can switch back and fotrh between console 5 (kde default), console 6 (strictly X without any kind of windows managers enabled) and console 7 (new kde launched in step 5) using 'ctrl-alt-f5', 'ctrl-alt-f6' and 'ctrl-alt-f7' combin-keys.
Yes, it seems to be a problem of Knoppix 5.Originally Posted by maxIT
If I start my old Knoppix 3.9 on the same hardware, all works too!
Ciao
Frank
Could it be the use of Xorg version 7.0 in Knoppix 5.0.1, rather than Xfree86 as in prior versions?

Lot of 38, Multiple Brands 16GB PC4-2400T/2666V/2133P/2933Y - Server Memory RAM
$3040.00
HPE 32GB 2Rx4 PC4-2933Y-R DDR4 Svr RAM P03052-091 P00924-B21 M393A4K40DB2-CVFBY
$270.00
Samsung 32GB (1x32GB) PC4-17000 (DDR4-2133) LRDIMM Memory (M386A4G40DM0-CPB0Q)
$120.00
2 in 1 USB 3.0 Card Reader Micro TF card Reader usb adapter High Speed Cardreder
$3.99
Lot of 13, Samsung and Hynix 32GB PC4-2400T/2666V/2133P - Server Memory RAM
$1950.00
USB 3.0 Flash Drive 32GB 64GB 128GB Memory Stick Thumb Stick Lot Pack
$826.09
Kingston 32GB 64GB 128GB 256GB USB 3.0 Flash Drive Thumb Memory Stick Pen lot
$285.90
Lot of 16 SK Hynix 64GB 2Rx4 DDR4-3200 ECC RDIMM Server Ram HMAA8GR7AJR4N-XN
$11200.00
SanDisk Cruzer Blade 16GB USB 2.0 Flash Drive Memory Stick - Lot of 50
$184.99
6 in 1 USB 3.0 Type C Card Reader SD Micro SD TF OTG Memory Adapter Laptop PC US
$3.95