According to man_history '! Start a history substitution...', but to me it return an error message:
bash: syntax error near unexpected token `newline'

The same behavior also in 'debian sarge' I've noticed.