-
Senior Member
registered user
Re: Why the "!" history feature doesn't work in kn

Originally Posted by
maxIT
According to man_history '! Start a history substitution...', but to me it return an error message:
bash: syntax error near unexpected token `newline'
The same behavior also in 'debian sarge' I've noticed.
Did you try to use plain "!"?
That is incorrect usage because man history clearly says that "!" only starts a history substitution when not followed by a blank, newline, = or (
! Start a history substitution, except when followed by a blank, newline, = or (.
!n Refer to command line n.
!-n Refer to the current command line minus n.
!! Refer to the previous command. This is a synonym for `!-1'.
At least on Knoppix 4.0.2 CD history expansion works as expected:
Code:
knoppix@0[knoppix]$ echo One
One
knoppix@0[knoppix]$ echo Two
Two
knoppix@0[knoppix]$ !
bash: syntax error near unexpected token `newline'
knoppix@0[knoppix]$ !-2
echo Two
Two
knoppix@0[knoppix]$ !-4
echo One
One
knoppix@0[knoppix]$ !!
echo One
One
Similar Threads
-
By carolus in forum General Support
Replies: 0
Last Post: 04-29-2008, 10:28 PM
-
By benny_mott in forum Hardware & Booting
Replies: 0
Last Post: 11-14-2006, 10:11 PM
-
By ockham23 in forum Knoppix DVD
Replies: 0
Last Post: 08-28-2005, 11:02 AM
-
By metavoid in forum Customising & Remastering
Replies: 0
Last Post: 08-31-2004, 11:13 PM
-
By Juny in forum General Support
Replies: 4
Last Post: 03-14-2003, 09:02 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD
$1299.99

IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620
$199.99

Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series
$375.00

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM
$179.99

IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU
$999.99

Compaq ProLiant 1500R 5/100 rack server, Series 3155, with IBM 2.1GB HD, VINTAGE
$295.00

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES
$110.30

IBM System x3550 M3 1U Server 2x Xeon E5645, 192GB RAM, 2x 300GB HDD (7944-AC1)
$150.00

Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs
$49.99

Lot of 3 IBM 00JY196 ServeRAID M1210 PCI Express SAS SATA Storage Controller
$68.99