Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: kernel panic:VFS:unable to mount root fs on 08:03

  1. #1
    Junior Member
    Join Date
    May 2003
    Posts
    6

    kernel panic:VFS:unable to mount root fs on 08:03

    Hi, I was trying to install knoppix in my old PC Server 325 dual pentium pro 180 with 128 Ram and 2 Hard disk (2,2 Gb anf 3,2 Gb).
    The installation finished with no problems, but when the system starts to boot, it stoops with:
    "kernel panic:VFS:unable to mount root fs on 08:03".
    Can anybody help me?
    Thanks in Advance.

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353

    Re: kernel panic:VFS:unable to mount root fs on 08:03

    Quote Originally Posted by ventallo
    Hi, I was trying to install knoppix in my old PC Server 325 dual pentium pro 180 with 128 Ram and 2 Hard disk (2,2 Gb anf 3,2 Gb).
    The installation finished with no problems, but when the system starts to boot, it stoops with:
    "kernel panic:VFS:unable to mount root fs on 08:03".
    Can anybody help me?
    Thanks in Advance.
    From a previous message:

    This is from the doc section on this site - from the cheat codes (which specify different boot options).

    "mem=128M
    Specify Memory size in MByte, Some Boards apparently don't pass the proper memory size to the linux-kernel. It may cause the message "Panic cannot mount root file system" and the system hangs. Use "knoppix mem=128M" to solve that problem if your system has 128MByte memory for example (caution you MUST use a capital "M" here)."

    So at the boot screen type:

    "knoppix mem=(whatever_your_mem_is)M"

    Also make sure that your cd doesn't have errors by typing this at boot: "knoppix testcd" (without the quotes)

  3. #3
    Junior Member
    Join Date
    May 2003
    Posts
    6

    kernel panic:VFS:unable to mount root fs on 08:03

    Do you mind explain me how can I put this command in the boot file?
    Because this starts automatically and I can't edit this file.
    When I put the knoppix cd all runs ok, and the installation in my Hard Disk is ok too.I only have the problem when the boot starts.

  4. #4
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479

    Re: kernel panic:VFS:unable to mount root fs on 08:03

    Quote Originally Posted by ventallo
    Do you mind explain me how can I put this command in the boot file?
    Because this starts automatically and I can't edit this file.
    When I put the knoppix cd all runs ok, and the installation in my Hard Disk is ok too.I only have the problem when the boot starts.
    Edit the file /etc/lilo.conf you are looking for the append line add mem=128M then save the file and run /sbin/lilo to commit the changes and re-boot. All this as root in a console window. A list of lilo error codes for future reference.

  5. #5
    Junior Member
    Join Date
    May 2003
    Posts
    6
    Thanks for the information that you posted, but I can not edit the lilo.conf file.
    I have not permissions for edit this file.I try to do this booting the knoppix cd and then I try to edit this file, but I have not permissions for writte it.
    Can anybody help me?
    Thanks.

  6. #6
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    Boot the disc like this:

    boot: knoppix mem=128M plus any other cheat codes you need to boot properly. Then reinstall. You don't have permission to write to the booted cd because it is read only.

  7. #7
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Quote Originally Posted by ventallo
    Thanks for the information that you posted, but I can not edit the lilo.conf file.
    I have not permissions for edit this file.I try to do this booting the knoppix cd and then I try to edit this file, but I have not permissions for writte it.
    Can anybody help me?
    Thanks.
    If you made a boot floppy when you installed then boot with it and at the boot: prompt then linux mem=128M and enter if the boot is successfull then follow the instructions above to change lilo.conf.

    From a cdrom boot:
    Open a console window and sudo mount /dev/hda1 /mnt/hda1
    then sudo gvim /mnt/hda1/etc/lilo.conf to open lilo for editing and add the mem=128M to the append line and save the file.
    then sudo chroot /mnt/hda1 /sbin/lilo -v to commit the changes to lilo and then re-boot.

  8. #8
    Junior Member
    Join Date
    May 2003
    Posts
    6
    Hi Stephen and friends, I've did it, all ok, but when the lilo runs again I have the same problem.
    I've edit lilo.conf, I've save it but then stooped with:
    apm: BIOS not found.
    VFS: cannot open root device 08:03
    Kernel panic: VFS: Unable to mount root fs on 08:03
    I'm desperate with this problem, it's strange because with the boot cd knoppix works with no problems, but when I try to install knoppix in my Hd I've this problems.
    Can anybody to said me other solution for solve this problem?
    I'll be waiting for any new.
    Thanks.

  9. #9
    Junior Member
    Join Date
    May 2003
    Posts
    6
    this is my lilo.conf file


    vga=791
    # /etc/lilo.conf - See: `lilo(' and `lilo.conf(5)',
    # --------------- `install-mbr(', `/usr/share/doc/lilo/',
    # and `/usr/share/doc/mbr/'.
    # +---------------------------------------------------------------+
    # | !! Reminder !! |
    # | |
    # | Don't forget to run `lilo' after you make changes to this |
    # | conffile, `/boot/bootmess.txt', or install a new kernel. The |
    # | computer will most likely fail to boot if a kernel-image |
    # | post-install script or you don't remember to run `lilo'. |
    # | |
    # +---------------------------------------------------------------+
    # Support LBA for large hard disks.
    #
    lba32
    # Overrides the default mapping between harddisk names and the BIOS'
    # harddisk order. Use with caution.
    #disk=/dev/hde
    # bios=0x81
    #disk=/dev/sda
    # bios=0x80
    # Specifies the boot device. This is where Lilo installs its boot
    # block. It can be either a partition, or the raw device, in which
    # case it installs in the MBR, and will overwrite the current MBR.
    #
    boot=/dev/sdb
    # Specifies the device that should be mounted as root. (`/')
    #
    root=/dev/sdb2
    # Enable map compaction:
    # Tries to merge read requests for adjacent sectors into a single
    # read request. This drastically reduces load time and keeps the
    # map smaller. Using `compact' is especially recommended when
    # booting from a floppy disk. It is disabled here by default
    # because it doesn't always work.
    #
    # compact
    # Installs the specified file as the new boot sector
    # You have the choice between: bmp, compat, menu and text
    # Look in /boot/ and in lilo.conf(5) manpage for details
    #
    install=/boot/boot-menu.b
    # Specifies the location of the map file
    #
    map=/boot/map
    # You can set a password here, and uncomment the `restricted' lines
    # in the image definitions below to make it so that a password must
    # be typed to boot anything but a default configuration. If a
    # command line is given, other than one specified by an `append'
    # statement in `lilo.conf', the password will be required, but a
    # standard default boot will not require one.
    #
    # This will, for instance, prevent anyone with access to the
    # console from booting with something like `Linux init=/bin/sh',
    # and thus becoming `root' without proper authorization.
    #
    # Note that if you really need this type of security, you will
    # likely also want to use `install-mbr' to reconfigure the MBR
    # program, as well as set up your BIOS to disallow booting from
    # removable disk or CD-ROM, then put a password on getting into the
    # BIOS configuration as well. Please RTFM `install-mbr('.
    #
    # password=tatercounter2000
    # Specifies the number of deciseconds (0.1 seconds) LILO should
    # wait before booting the first image.
    #
    delay=20
    # You can put a customized boot message up if you like. If you use
    # `prompt', and this computer may need to reboot unattended, you
    # must specify a `timeout', or it will sit there forever waiting
    # for a keypress. `single-key' goes with the `alias' lines in the
    # `image' configurations below. eg: You can press `1' to boot
    # `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
    #
    # message=/boot/bootmess.txt
    # prompt
    # single-key
    # delay=100
    # timeout=100
    # Kernel command line options that apply to all installed images go
    # here. See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
    # the Linux kernel `Documentation' directory.
    #
    # append="mem=128M"
    append="hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi apm=power-off nomce"
    # Boot up Linux by default.
    #
    default=Linux
    image=/boot/vmlinuz-2.4.20-xfs
    label=Linux
    initrd=/boot/initrd.gz
    read-only
    # restricted
    # alias=1
    image=/vmlinuz.old
    label=LinuxOLD
    read-only
    optional
    # restricted
    # alias=2
    # If you have another OS on this machine to boot, you can uncomment the
    # following lines, changing the device name on the `other' line to
    # where your other OS' partition is.
    #
    # other=/dev/hda4
    # label=HURD
    # restricted
    # alias=3

  10. #10
    Senior Member registered user
    Join Date
    Jan 2003
    Location
    Podunk, Idaho, USA
    Posts
    470
    I see from your lilo.conf file that you've installed to your second scsi drive. What is your exact partition layout on that drive?

    As for the mem=128M statement, it should be put in your append line like this:

    append="hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi apm=power-off nomce mem=128M"


    HTH

    rock

Page 1 of 2 12 LastLast

Similar Threads

  1. Kernel panic: VFS: Unable to mount root fs on ram3
    By SiKing in forum Hardware & Booting
    Replies: 5
    Last Post: 11-09-2005, 11:21 AM
  2. Kernel Panic: VFS: Unable to mount root fs on 21:02
    By helkyd in forum Hardware & Booting
    Replies: 1
    Last Post: 05-14-2004, 02:19 PM
  3. Kernel panic: VFS : Unable to mount root fs on 03:02
    By biohazard in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 12-26-2003, 02:55 AM
  4. "Panic cannot mount root file system might help
    By teagab in forum General Support
    Replies: 0
    Last Post: 10-04-2003, 02:34 PM
  5. Kernel Panic: Cannot mount root-fs (SCSI driver missing)
    By ullmanns in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 07-08-2003, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


5 Port Gigabit Unmanaged Ethernet Switch, Home Network Hub, Office Ethernet S... picture

5 Port Gigabit Unmanaged Ethernet Switch, Home Network Hub, Office Ethernet S...

$9.64



NETGEAR GS308EP Essential Series 8-Port Gigabit PoE+ Unmanaged Switch picture

NETGEAR GS308EP Essential Series 8-Port Gigabit PoE+ Unmanaged Switch

$49.99



TP-Link TL-SG1048 48-Port Gigabit Rackmount Switch New Factory Sealed picture

TP-Link TL-SG1048 48-Port Gigabit Rackmount Switch New Factory Sealed

$199.99



Cisco Catalyst 2960-48TT-L 48-Port Fast Ethernet Managed Rackmount Switch picture

Cisco Catalyst 2960-48TT-L 48-Port Fast Ethernet Managed Rackmount Switch

$46.99



TP-Link TL-SG105 5-Port Gigabit Ethernet Unmanaged Metal Desktop Network Switch picture

TP-Link TL-SG105 5-Port Gigabit Ethernet Unmanaged Metal Desktop Network Switch

$19.99



10-Port Gigabit PoE Network Switch with 8 PoE+ Ports with 2 Combo SFP Slots 125W picture

10-Port Gigabit PoE Network Switch with 8 PoE+ Ports with 2 Combo SFP Slots 125W

$39.99



TP-Link TL-SG105, 5 Port Gigabit Unmanaged Ethernet Switch, Network Hub, Ethern picture

TP-Link TL-SG105, 5 Port Gigabit Unmanaged Ethernet Switch, Network Hub, Ethern

$15.25



Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch with rack mounts picture

Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch with rack mounts

$69.00



D-Link DGS-1210-28P 28-Port PoE Gigabit Web Smart Switch With Cord picture

D-Link DGS-1210-28P 28-Port PoE Gigabit Web Smart Switch With Cord

$49.99



HP ProCurve J9265A 6600-24XG 10GBE Layer3 Gigabit Switch w/ 2 x PSU picture

HP ProCurve J9265A 6600-24XG 10GBE Layer3 Gigabit Switch w/ 2 x PSU

$180.20