Results 1 to 5 of 5

Thread: Setting up file servers (5.0.1) - /usr/bin/X11/xauth error?

Hybrid View

  1. #1
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256

    Setting up file servers (5.0.1) - /usr/bin/X11/xauth error?

    Hi All,

    I just got 2 new fast servers to replace some old slow ones. I use these servers for my students to login each day so they can edit and compile *.java files for my AP Computer Science classes. My students use ssh and fish:// to access all their work remotely on campus and from home.

    I set both these servers up the exact same way and the server hardware is identical (Pentium IV, 40GB hdd, etc) except one has 1GB and the other has 2GB of RAM. I used the KNOPPIX 5.0.1 CD to install as Debian on the hdd.

    I setup
    netcardconfig to initailize the ip address on eth0 by DHCP and
    update-rc.d ssh default
    for a ssh server (sshd) and I added all my users with adduser.

    Now, on the 1GB server, the first time a new user logs in, Xauthority is called and all is well. However, the first time a user logs into the 2GB server, an error comes up like

    Could not chdir to home directory /home/userid: Permission denied
    /usr/bin/X11/xauth: timeout in locking authority file /home/userid/.Xauthority


    instead of Xauthority running. The user then gets dumped outside of the /home dir and cannot cd into it or into /home/userid!

    Have any of you stalwart linux gurus dealt with anything like this before? If so, please let me know what your solution was! I've never had a problem like this before and I've been setting up servers like this using KNOPPIX for years....

    TIA,
    AJG

  2. #2
    Senior Member registered user
    Join Date
    Mar 2004
    Posts
    1,516
    my first guess is permissions, but as you say they are 100% equal... could it be that the knoppix kernel lack the support formuch ram in the kernel?? sounds odd.

  3. #3
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256
    Well, the only thing I forgot to mention is that I setup these servers last week with only root and one regular user and I think both root and the regular user could login remotely to both servers via
    ssh [email protected].x.x using konsole or
    fish://[email protected] using konqueror.

    Today, I just added about 30 new users to each server and that's when the problem began. I don't know what adding users could possibly affect, but that's all I did today and all is well on the 1GB server and noone but root can log into the 2GB server and I cannot chdir to /home unless I'm root!

    BTW, I don't think it has anything to do with the size of the RAM, I'm just mentioning the RAM size so I can distinguish one server from the other for our conversation here.

    Regards,
    AJG

  4. #4
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256
    Oh, and as far as permissions go, the only ones I change are those to the user directories in /home. These default to 755 but I chmod them to 700 so that a user can access his/her own files, but cannot see other users' files....

    Like I said, I always do this and have had no problems, but I just thought I should mention it.

    Maybe I could create an .Xauthority file for each user myself?

    Would a lspci -v dump help you help me?

    TIA,
    AJG

  5. #5
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256
    False alarm! I just figured out how I FUBARed my own server....

    As root, instead of issuing the commandline
    chmod 700 /home/*
    I issued the commandline
    chmod 700 /home

    I fixed it and now all is well with the world.

    Apparently I did it right on the other server....

    Sorry!

    MY BAD!!

    Never Mind!!!

    Thax anyway,
    AJG

Similar Threads

  1. Error setting up re-master session
    By WallyWallWhackr in forum Customising & Remastering
    Replies: 6
    Last Post: 04-29-2008, 01:39 AM
  2. Strange Network Problem - Setting up file server
    By pstone in forum Networking
    Replies: 7
    Last Post: 07-16-2007, 12:33 PM
  3. file:///mnt/cdrom Error
    By Matabus in forum General Support
    Replies: 1
    Last Post: 07-04-2005, 12:08 AM
  4. An error in untarring a file ?
    By gopikrish in forum General Support
    Replies: 3
    Last Post: 08-22-2004, 05:36 AM
  5. png file error
    By 3133 in forum Customising & Remastering
    Replies: 0
    Last Post: 04-14-2003, 12:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM picture

Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM

$1499.00



Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram  2x 550W PSU No HDD picture

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD

$275.00



867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001 picture

867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001

$245.00



Dell PowerEdge R530 2x E5-2630v4 H330 iDRAC8 Port Card Riser No PSU/RAM/HDD picture

Dell PowerEdge R530 2x E5-2630v4 H330 iDRAC8 Port Card Riser No PSU/RAM/HDD

$99.99



Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO picture

Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO

$308.00



Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2690 v3 | 64gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2690 v3 | 64gb Ram | 2x 1600W

$524.99



Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W

$409.99



Supermicro 2U GPU Server SYS-2029GP-TR 2x Xeon 6130 32C 6x PCIe 3.0 x16 Slots picture

Supermicro 2U GPU Server SYS-2029GP-TR 2x Xeon 6130 32C 6x PCIe 3.0 x16 Slots

$745.00



Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb picture

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb

$374.99



Dell PowerEdge FX2s + 8x FC430 Blades 16x E5-2630v4 160 Cores Rails No PSU/RAM picture

Dell PowerEdge FX2s + 8x FC430 Blades 16x E5-2630v4 160 Cores Rails No PSU/RAM

$699.00