Results 1 to 7 of 7

Thread: Adding Canon printer

  1. #1
    Junior Member
    Join Date
    Apr 2007
    Posts
    8

    Adding Canon printer

    I am trying to add a cannon BJC-240 printer it is unable to find the suggested driver message is as follows:-
    "Either the driver does not exist or you do not have the correct previlage". I am in administrator mode.

    Any suggestions please

  2. #2
    Member registered user
    Join Date
    Jul 2006
    Location
    toronto, canada
    Posts
    87
    You didn't say which version you have, but this may be the fix. I had this problem with knoppix 5.0. The problem was NOT permissions, but the driver list. Check the ESP drivers for a canon driver. Version 5.1 (the latest) dropped the ESP drivers, in line with earlier versions.

    If you have 5.0, try the ESP drivers, and let me know if this helps.

  3. #3
    Junior Member
    Join Date
    Apr 2007
    Posts
    8

    Cannon printer

    I am using Knoppix 5.1, it shows the driver list including Omni drivers, but error happens when I select the driver and click next. On a another note how do you start the CUPS print Server?

  4. #4
    Member registered user
    Join Date
    Jul 2006
    Location
    toronto, canada
    Posts
    87
    You wrote "Knoppix 5.1, it shows the driver list including Omni drivers, but error happens when I select the driver and click next. "

    I checked my knoppix journal (I have found it pays to keep written or printed records of experiments, etc.) , and yes, the CUPS server must be (re)started.

    K -> knoppix -> configure -> configure printers
    Print Server -> Restart server

    Version 5.1.0 dropped the ESP drivers, but that version featured the need to manually restart CUPS. Also, it introduced the error - 'unable to create temporary printer'. The only way I could resolve that was with the new version.

    5.1.1 came out around January 7. That one fixed the printer problem, and is the latest to date. I know that 5.2 is in the pipeline, but I don't know when to expect it.

    Give 5.1.1 a try and let me know if that fixes your problem, which sounds the same as mine.

  5. #5
    Junior Member
    Join Date
    Apr 2007
    Posts
    8
    The Knoppix version I am using is 5.1.8.1 site says it is the current!

    I have tried what you suggested to start CUPS the error reported is "Unable to find a running CUPS server"

    What next, yey nobody does any printing in the Linux world?

  6. #6
    Member registered user
    Join Date
    Jul 2006
    Location
    toronto, canada
    Posts
    87
    This is odd - go to http://torrent.unix-ag.uni-kl.de/

    5.1.1, with a release date of jan 4, 2007 is the latest. I just did a google for 5.1.8.1 and knoppix, and I find SLAX 5.1.8.1, but not knoppix.

    Does anyone else have any input on this?

  7. #7
    Junior Member
    Join Date
    Apr 2007
    Posts
    8
    You are right the version is KNOPPIX_V5.1.1CD-2007-01-04-EN.iso, I have managed to starts CUPS as follows
    /usr/sbin/cupsd.
    My printer is an old parallel printer (Canon BJC-240), CUPS does not allow me to add a parallel printer, what should I have to do to get this working under Knoppix or it too involved?

Similar Threads

  1. Adding a Printer
    By LAF in forum Networking
    Replies: 1
    Last Post: 06-09-2007, 12:15 AM
  2. adding a printer in 5.0.1
    By ndb in forum General Support
    Replies: 0
    Last Post: 09-08-2006, 07:45 PM
  3. Replies: 0
    Last Post: 02-02-2006, 04:03 AM
  4. Printer Canon PIXMA iP1500
    By waterproof in forum Hardware & Booting
    Replies: 0
    Last Post: 10-24-2005, 08:26 PM
  5. How to install Canon LBP460 printer
    By K Behrens in forum Hardware & Booting
    Replies: 1
    Last Post: 01-18-2005, 08:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W

$484.99



Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed picture

Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed

$41.19



VMware vCenter Server 8 STANDARD Perpetual License Key VC-STD-C (Legacy Pack) picture

VMware vCenter Server 8 STANDARD Perpetual License Key VC-STD-C (Legacy Pack)

$1599.95



Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram  2x 550W PSU No HDD picture

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD

$275.00



Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p picture

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p

$499.88



Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO picture

Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO

$308.00



Supermicro 2U GPU Server SYS-2029GP-TR 2x Xeon 6130 32C 6x PCIe 3.0 x16 Slots picture

Supermicro 2U GPU Server SYS-2029GP-TR 2x Xeon 6130 32C 6x PCIe 3.0 x16 Slots

$745.00



Dell PowerEdge C4130 1U AI GPU Server E5-2698 V4 | No RAM | 2x 1600W PSU picture

Dell PowerEdge C4130 1U AI GPU Server E5-2698 V4 | No RAM | 2x 1600W PSU

$414.99



DELL POWEREDGE R340 Server | Xeon E-2126G 64GB RAM PERC H330 (Onboard) picture

DELL POWEREDGE R340 Server | Xeon E-2126G 64GB RAM PERC H330 (Onboard)

$399.95



MICROSOFT WINDOWS SERVER 2025 RDS 50 CAL NEW Factory Sealed picture

MICROSOFT WINDOWS SERVER 2025 RDS 50 CAL NEW Factory Sealed

$136.87