It looks like the problem was with my hard drive. It has passed it's prime and due for retirement. R.I.P. my Hitcachi Travelstar...
I am having trouble getting write access to my Windows partition, which fails to boot now. I want to try to try some repair techniques but it requires moving files around, which requires write access.
It is an NTFS partition.
On Knoppix, it mounted the device as:
/dev/hda1 on mount point /media/hda1
The first thing I tried doing, is right-clicking the hard disk icon on desktop and chose "change read/write mode". Said yes to the popup and then got the following message: "The remount command failed. Maybe there is another process accessing the filesystem currently".
Then I looked online and found a command I could try on the command line, so I wrote it as this:
mount -t ntfs -o rw /dev/hda1 /media/hda1
And I get the following response:
Failed to mount '/dev/hda1': Operation is not supported
Mount is denied because NTFS is unclean. Choose one of these actions:
...
The first option had something to do with making sure windows shut down cleanly- not sure how it determines that but anyway this is impossible because windows crashed.
The last option was to mount in read-only mode. Not what I want.
So I try the second option which is to run ntfsfix, typing: ntfsfix /dev/hda1
and it just hanging there. unless this is supposed to take a really long time (over 10 minutes now) then I think it's safe to say it ain't working. (though I am still leaving it to hang there, afraid to try and cancel it. hoping by some miracle it will finish)
Any other ideas?
It looks like the problem was with my hard drive. It has passed it's prime and due for retirement. R.I.P. my Hitcachi Travelstar...
I had that error too. That happened sometimes when I tried to mount my hard disk after I started my internet or internet browser. I fixed it by mounting my hard disk immediately after startup (before starting any program), and then saving my settings in the configuration archive."The remount command failed. Maybe there is another process accessing the filesystem currently"
The next time I started Knoppix the problem was solved and mounting was no problem anyway!
This problem also appeared at my hard disk lately. I'm not sure how I solved it at that moment....probably it was shutting down Knoppix, booting Windows and starting Knoppix again.Failed to mount '/dev/hda1': Operation is not supported
Mount is denied because NTFS is unclean. Choose one of these actions:
...
But...that won't work for you, because your Windows crrrrashed.
Maybe you could try restarting Knoppix and then immediately mounting the disk after startup?

Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM
$1499.00
Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD
$275.00
867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001
$245.00
Dell PowerEdge R530 2x E5-2630v4 H330 iDRAC8 Port Card Riser No PSU/RAM/HDD
$99.99
Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2690 v3 | 64gb Ram | 2x 1600W
$524.99
Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W
$409.99
Dell PowerEdge C4130 1U AI GPU Server | 2x E6-2699 v3 | 128gb RAM | 2x 1600W
$899.99
Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO
$308.00
Dell PowerEdge FX2s + 8x FC430 Blades 16x E5-2630v4 160 Cores Rails No PSU/RAM
$699.00
RDS CAL - Remote Desktop Services Windows Server 2019 50 User/Device Connections
$63.00