Hi everybody.
I'm writing to search for help about a problem i'm experiencing.
I'm using knoppix as host system for a virtualized computing-grid testbed, implemented as two Scientific Linux (RHEL like) guests launched by the qemu emulator.
Two scenarios follow:
1) I boot a Knoppix "vanilla" system (which get access, when ready, to the local disks). As the system become ready, I install qemu, uml-utilites,bridge-utils (via apt-get), and I run qemu to virtualize two pre-installed Scientific Linux images (laying on my main physical disc). Everything goes ok.
2) I remaster Knoppix to include qemu/bridge-utils/uml-utilites and the two SL images. When finished, I restart the whole system and boot from the new, remastered, knoppix DVD. When the booting phase ends, I try to launch my qemu-ed images. Both of the images, when trying to chroot to /, fail with a bad kernel panic (with a different initial message).
Does someone know what is the reason for this to happen? Why this behaviour difference within the two previous environments?
I've to precise that both images are "mirrored": they have the same OS and Filesystem installed on.
Thank you in advance,
Alex.
N.B: Kernel Panic detailed messages are as it follows:
<FIRST RUNNED IMAGE>
Redhat nash version 4.2.1.8 starting
Mounted /proc filesystem
Mounting sysfs
Creating /dev
Starting udev
Creating root device
Mounting root filesystem
EXT2-fs: magic mismatch, very weird!
Mount: error 22 mounting EXT2
Mount: error 2 mounting none
Switching to the new root
Switchroot: mount failed: 22
mount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
<END OF FIRST IMAGE MESSAGE>
<SECOND RUNNED IMAGE>
Redhat nash version 4.2.1.8 starting
Mounted /proc filesystem
Mounting sysfs
Creating /dev
Starting udev
Creating root device
Mounting root filesystem
VFS: couldn't find ext2 filesystem on dev hda1
Mount: error 22 mounting EXT2
Mount: error 2 mounting none
Switching to the new root
Switchroot: mount failed: 22
mount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
<END OF SECOND IMAGE MESSAGES>

IBM Power S822 POWER8 1x CPU 32GB DDR4 RAM 2U Rack Server No HDD.
$629.99
Lot of 2 IBM blade center Type H chassis 8852
$559.00
IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU
$200.00
IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM
$149.99
IBM 4262 SYSTEM x3200 Tower - HDD Wiped, NO OS
$80.00
IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES
$108.92
IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU
$999.99
IBM System x3550 M3 1U Server 2x Xeon E5645, 192GB RAM, 2x 300GB HDD (7944-AC1)
$135.00
IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620
$199.99
IBM System x3755 M3 2U Rackmount Server – No Drives or Trays
$150.00