Results 1 to 6 of 6

Thread: (SOLVED) error inserting '/cdrom/KNOPPIX/modules/cloop.ko':

  1. #1
    Junior Member
    Join Date
    Sep 2007
    Posts
    2

    (SOLVED) error inserting '/cdrom/KNOPPIX/modules/cloop.ko':

    I thought I would use Knoppix to boot my old Proliant DL380. The Knoppix (5.1.1) is able to boot an ordinary white box, but not the Proliant. The kernel loads and then very early in the hardware detection it returns the error:
    insmod: error inserting '/cdrom/KNOPPIX/modules/cloop.ko': -
    The problem is very similar to this, only I can't see how it can be a problem with the disk when it can be used to boot other computers. Any clues?

    Thanks for reading.

    Regards

    Fog_Watch.

    PS. This beast usually needs a cpqarray module loaded. I don't know if that is an issue.

  2. #2
    Administrator Site Admin-
    Join Date
    Apr 2003
    Location
    USA
    Posts
    5,441

    Re: insmod: error inserting '/cdrom/KNOPPIX/modules/cloop.ko

    Quote Originally Posted by Fog_Watch
    I thought I would use Knoppix to boot my old Proliant DL380. The Knoppix (5.1.1) is able to boot an ordinary white box, but not the Proliant. The kernel loads and then very early in the hardware detection it returns the error:
    insmod: error inserting '/cdrom/KNOPPIX/modules/cloop.ko': -
    The problem is very similar to this, but I don't want to accept the advice given in that thread or the downloading faq, or post what speed I burnt the disc at (leaving others only able to guess what the problem is). I don't want to accept that there can be small differences in different optical drives that might account for this and I refuse to see how it can be a problem with the disk when it can be used to boot other computers. Even though the disc clearly boots on one system and not another. Any clues?

    Thanks for reading.

    Regards

    Fog_Watch.

    PS. This beast usually needs a cpqarray module loaded. I don't know if that is an issue.
    I have no additional help to offer that you seem ready to accept.

  3. #3
    Senior Member registered user
    Join Date
    Jun 2005
    Posts
    348
    Fog_Watch

    You may very well have found the problem and answer, but you seem to refuse to accept the solution. Many disks that are burned at higher speeds may simply not work well in ALL optical drives. This may be the issue you encountered, especially with older hardware. Higher burn speeds seem to create some drive compatibility issues. It is encountered quite often with Audio CDs that don't play well, or at all in some CD players, but play well in others. Burning the disc at a slow speed usually resolves the compatability issue. Like it or not, it's a common problem.

    Another issue could be that the drive/hardware is unable to work well with DMA acceleration or without it. The "knoppix nodma" cheatcode may help by disabling it, or "knoppix dma" to enable DMA acceleration. I'm not sure if 5.1.1 is enabled or disabled by default. You can try one or the other to see if that solves your problem.

  4. #4
    Junior Member
    Join Date
    Sep 2007
    Posts
    2
    Quote Originally Posted by ckamin
    refuse to accept the solution.
    I accept the possibility of writing speed being the cause of the problem. I, however, found a different solution.
    Quote Originally Posted by ckamin
    "knoppix nodma"
    This did not alter the error

    The solution was to use KNOPPIX_V4.0.2. This booted the machine fine. A small problem was it not having lvm v2, but I get this off a floppy (after modprobe dm_mod) to solve that problem. This solution did not surprise me as a Gentoo 2007 disk does not boot the machine but a 2006 does.

    Harry Kuhman and ckamin, thank you both for your replies.

    Regards
    Fog_Watch

  5. #5
    Administrator Site Admin-
    Join Date
    Apr 2003
    Location
    USA
    Posts
    5,441
    Quote Originally Posted by Fog_Watch
    The solution was to use KNOPPIX_V4.0.2. This booted the machine fine.
    In many ways I find 4.02 to be superior to any of the 5.x discs. But the fact that a different disc, even a 4.02 one, does boot just reinforces the belief that the failing disc was likely made at high speed and that another one burnt at slower speed would likely boot as well. Of course, there can be other differences such as media quality, but speed of burn is the most common issue that we see here.
    ---
    Verifying of md5 checksum and burning a CD at slow speed are important.

  6. #6
    Junior Member
    Join Date
    Nov 2007
    Posts
    1
    I experienced the same error while booting a Knoppix ISO within Virtualbox. The burning speed suggestion isn't very helpful on this issue now. Any ideas?

    Thanks for any help,
    falken

Similar Threads

  1. Problem with "error inserting '/modules/cloop.ko':"
    By flognat in forum General Support
    Replies: 5
    Last Post: 05-08-2007, 06:57 PM
  2. FATAL: Error inserting cloop : Invalid argument
    By wsun013 in forum Customising & Remastering
    Replies: 0
    Last Post: 05-03-2006, 01:15 PM
  3. error inserting' /modules/cloop.ko' : -bad file number
    By syruice in forum General Support
    Replies: 9
    Last Post: 01-08-2006, 03:19 PM
  4. error inserting '/modules/cloop.o': -1 Bad file number
    By Droide in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 08-08-2005, 04:11 PM
  5. Cloop modules Unresolved symbols [SOLVED].....
    By psirac in forum Customising & Remastering
    Replies: 0
    Last Post: 09-08-2004, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


IBM POWER8 8286-42A S824 8-Core 128GB RAM 4.8TB SAS Fedora Linux Server PowerVM picture

IBM POWER8 8286-42A S824 8-Core 128GB RAM 4.8TB SAS Fedora Linux Server PowerVM

$750.00



Lot of 2 IBM blade center Type H chassis 8852 picture

Lot of 2 IBM blade center Type H chassis 8852

$559.00



IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU picture

IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU

$200.00



IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM

$149.99



IBM Power S822 POWER8 1x CPU 32GB DDR4 RAM 2U Rack Server No HDD. picture

IBM Power S822 POWER8 1x CPU 32GB DDR4 RAM 2U Rack Server No HDD.

$629.99



IBM Power S922 9009-22A Power9 DDR4 10GbE 6X SFF Barebone Server picture

IBM Power S922 9009-22A Power9 DDR4 10GbE 6X SFF Barebone Server

$999.95



IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU picture

IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU

$999.99



IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES picture

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES

$108.92



IBM System X3650 M3 Server Xeon E5620 2.4 GHz 16 GB Ram Raid M5015 No OS No HDD picture

IBM System X3650 M3 Server Xeon E5620 2.4 GHz 16 GB Ram Raid M5015 No OS No HDD

$87.96



IBM QRadar xx29 M4 2x Xeon E5-2670 2.6GHz 16-Cores | 64gb | M5120 RAID picture

IBM QRadar xx29 M4 2x Xeon E5-2670 2.6GHz 16-Cores | 64gb | M5120 RAID

$349.99